summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-12-10 00:31:39 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-12-10 00:33:37 +0100
commit076ea20234fb2c06ebfc12367c78dda938a0c579 (patch)
treeec355f2d603ebe009fd671e3e48b27029b272753 /dev-php/phpspec-prophecy/phpspec-prophecy-1.9.0.ebuild
parentdev-php/PHPMailer: bump to v6.1.3 (diff)
downloadgentoo-076ea20234fb2c06ebfc12367c78dda938a0c579.tar.gz
gentoo-076ea20234fb2c06ebfc12367c78dda938a0c579.tar.bz2
gentoo-076ea20234fb2c06ebfc12367c78dda938a0c579.zip
dev-php/phpspec-prophecy: bump to v1.9.0
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/phpspec-prophecy/phpspec-prophecy-1.9.0.ebuild')
-rw-r--r--dev-php/phpspec-prophecy/phpspec-prophecy-1.9.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-php/phpspec-prophecy/phpspec-prophecy-1.9.0.ebuild b/dev-php/phpspec-prophecy/phpspec-prophecy-1.9.0.ebuild
new file mode 100644
index 000000000000..846a5675c108
--- /dev/null
+++ b/dev-php/phpspec-prophecy/phpspec-prophecy-1.9.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PN="prophecy"
+MY_VENDOR="phpspec"
+
+DESCRIPTION="Highly opinionated mocking framework"
+HOMEPAGE="https://github.com/${MY_VENDOR}/${MY_PN}"
+SRC_URI="https://github.com/${MY_VENDOR}/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ <dev-php/doctrine-instantiator-2
+ <dev-php/phpdocumentor-reflection-docblock-4
+ <dev-php/sebastian-comparator-3
+ <dev-php/sebastian-recursion-context-4
+ >=dev-lang/php-5.6:*"
+
+src_install() {
+ insinto /usr/share/php/${MY_VENDOR}/Prophecy
+ doins -r src/Prophecy/*
+ doins "${FILESDIR}/autoload.php"
+}