summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-11-29 20:33:51 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-11-29 20:35:10 +0100
commitf5485b7a5dbfd68ef35ed95da1cbe1a849c308c1 (patch)
tree78b29af0df3e9a3cfea6f60e0b96cc693c2137e4 /dev-php/realpath_turbo/realpath_turbo-2.0.0.ebuild
parentdev-php/swoole-async: initial import of v4.4.12 (diff)
downloadgentoo-f5485b7a5dbfd68ef35ed95da1cbe1a849c308c1.tar.gz
gentoo-f5485b7a5dbfd68ef35ed95da1cbe1a849c308c1.tar.bz2
gentoo-f5485b7a5dbfd68ef35ed95da1cbe1a849c308c1.zip
dev-php/realpath_turbo: initial import of v2.0.0
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/realpath_turbo/realpath_turbo-2.0.0.ebuild')
-rw-r--r--dev-php/realpath_turbo/realpath_turbo-2.0.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-php/realpath_turbo/realpath_turbo-2.0.0.ebuild b/dev-php/realpath_turbo/realpath_turbo-2.0.0.ebuild
new file mode 100644
index 000000000000..629ec768de12
--- /dev/null
+++ b/dev-php/realpath_turbo/realpath_turbo-2.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PHP_EXT_NAME="realpath_turbo"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php5-6 php7-1 php7-2 php7-3 php7-4"
+
+inherit php-ext-source-r3
+
+MY_PV="${PV/_/}"
+
+DESCRIPTION="PHP extension to re-enable realpath cache when using open_basedir restriction"
+HOMEPAGE="https://github.com/Whissi/${PN}/"
+SRC_URI="https://github.com/Whissi/${PN}/releases/download/v${MY_PV}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+DOCS=( ChangeLog CREDITS LICENSE README.md )