summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-12-19 13:36:47 -0500
committerBrian Evans <grknight@gentoo.org>2019-12-19 14:46:56 -0500
commite3299f8b6b615a02f78dd06fc97cc2b4bb005b8a (patch)
tree531d30e58074e0ce0c67f8724c4dd8beb80e04e9 /dev-php/sebastian-environment/sebastian-environment-4.2.3.ebuild
parentdev-php/PHP_TokenStream: Version bump to 3.1.3 (diff)
downloadgentoo-e3299f8b6b615a02f78dd06fc97cc2b4bb005b8a.tar.gz
gentoo-e3299f8b6b615a02f78dd06fc97cc2b4bb005b8a.tar.bz2
gentoo-e3299f8b6b615a02f78dd06fc97cc2b4bb005b8a.zip
dev-php/sebastian-environment: Version bump for 4.2.3
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/sebastian-environment/sebastian-environment-4.2.3.ebuild')
-rw-r--r--dev-php/sebastian-environment/sebastian-environment-4.2.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-php/sebastian-environment/sebastian-environment-4.2.3.ebuild b/dev-php/sebastian-environment/sebastian-environment-4.2.3.ebuild
new file mode 100644
index 000000000000..49b0a247a1d0
--- /dev/null
+++ b/dev-php/sebastian-environment/sebastian-environment-4.2.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/sebastian-//}"
+
+DESCRIPTION="Helps writing PHP code that has runtime-specific execution paths"
+HOMEPAGE="http://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-7.1:*"
+
+src_install() {
+ insinto /usr/share/php/SebastianBergmann/Environment
+ doins -r src/*
+ newins "${FILESDIR}/autoload-4.2.3.php" autoload.php
+}