summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-07-10 11:16:28 -0400
committerBrian Evans <grknight@gentoo.org>2017-07-10 11:34:15 -0400
commit6c259c3d23980ad6cfdd1c0ccb6ae542afd1dfcd (patch)
treebad953dfc1b456586729fe3cac23a7eb4f7c6c49 /dev-php/securimage/securimage-3.6.5.ebuild
parentdev-php/mmslib: Update EAPI (diff)
downloadgentoo-6c259c3d23980ad6cfdd1c0ccb6ae542afd1dfcd.tar.gz
gentoo-6c259c3d23980ad6cfdd1c0ccb6ae542afd1dfcd.tar.bz2
gentoo-6c259c3d23980ad6cfdd1c0ccb6ae542afd1dfcd.zip
dev-php/securimage: Version bump to 3.6.5
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-php/securimage/securimage-3.6.5.ebuild')
-rw-r--r--dev-php/securimage/securimage-3.6.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-php/securimage/securimage-3.6.5.ebuild b/dev-php/securimage/securimage-3.6.5.ebuild
new file mode 100644
index 000000000000..a43db24e9395
--- /dev/null
+++ b/dev-php/securimage/securimage-3.6.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="PHP captcha creator and validator library"
+HOMEPAGE="http://phpcaptcha.org/"
+SRC_URI="https://github.com/dapphp/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/php[gd,truetype]
+ virtual/httpd-php"
+
+src_install()
+{
+ # Grab all PHP files except the examples.
+ set *.php
+ local php_files=${@/*example*/}
+
+ insinto /usr/share/php/${PN}
+ doins -r ${php_files} *.{ttf,swf} audio backgrounds database images words
+
+ dodoc README*
+}