summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-07-18 14:17:27 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-07-18 15:01:19 +0200
commitaca9bc4fbc8150c6f0f6593485b9d02e7c4d2029 (patch)
treef6ad1707dd4fcd0d11d2783d8d2635cdedfdfd12 /dev-php/symfony-console/symfony-console-2.8.50.ebuild
parentdev-php/composer: bump to v1.8.6 (diff)
downloadgentoo-aca9bc4fbc8150c6f0f6593485b9d02e7c4d2029.tar.gz
gentoo-aca9bc4fbc8150c6f0f6593485b9d02e7c4d2029.tar.bz2
gentoo-aca9bc4fbc8150c6f0f6593485b9d02e7c4d2029.zip
dev-php/symfony-console: bump to v2.8.50
security release Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/symfony-console/symfony-console-2.8.50.ebuild')
-rw-r--r--dev-php/symfony-console/symfony-console-2.8.50.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-php/symfony-console/symfony-console-2.8.50.ebuild b/dev-php/symfony-console/symfony-console-2.8.50.ebuild
new file mode 100644
index 000000000000..3586a72bfe27
--- /dev/null
+++ b/dev-php/symfony-console/symfony-console-2.8.50.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Subtree split of the Symfony Console Component"
+HOMEPAGE="https://github.com/symfony/console"
+SRC_URI="https://github.com/symfony/console/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader
+ >=dev-php/psr-log-1.0.2
+ >=dev-php/symfony-event-dispatcher-2.1.0
+ >=dev-php/symfony-process-2.8.12"
+
+S="${WORKDIR}/console-${PV}"
+
+src_install() {
+ insinto "/usr/share/php/Symfony/Component/Console"
+ doins -r . "${FILESDIR}"/autoload.php
+ dodoc README.md
+}