summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-11-30 00:43:08 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-11-30 01:39:15 +0100
commit739fa84718fe264256b32073499c233336093d21 (patch)
tree1e0441558b28e1dfd5935e058ad3cce1a2c4cf12 /dev-php/theseer-tokenizer/theseer-tokenizer-1.2.0.ebuild
parentdev-php/theseer-Autoload: new package (diff)
downloadgentoo-739fa84718fe264256b32073499c233336093d21.tar.gz
gentoo-739fa84718fe264256b32073499c233336093d21.tar.bz2
gentoo-739fa84718fe264256b32073499c233336093d21.zip
dev-php/theseer-tokenizer: bump to v1.2.0
Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/theseer-tokenizer/theseer-tokenizer-1.2.0.ebuild')
-rw-r--r--dev-php/theseer-tokenizer/theseer-tokenizer-1.2.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-php/theseer-tokenizer/theseer-tokenizer-1.2.0.ebuild b/dev-php/theseer-tokenizer/theseer-tokenizer-1.2.0.ebuild
new file mode 100644
index 000000000000..20e9ed3dcae2
--- /dev/null
+++ b/dev-php/theseer-tokenizer/theseer-tokenizer-1.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Convert tokenized PHP source code into XML and other formats"
+HOMEPAGE="https://github.com/theseer/tokenizer"
+SRC_URI="https://github.com/theseer/tokenizer/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+CDEPEND="dev-lang/php:*
+ dev-php/fedora-autoloader"
+
+BDEPEND="dev-php/theseer-Autoload"
+
+RDEPEND="${CDEPEND}"
+
+S="${WORKDIR}/tokenizer-${PV}"
+
+src_prepare() {
+ default
+
+ phpab \
+ --output src/autoload.php \
+ --template fedora2 \
+ --basedir src \
+ src || die
+}
+
+src_install() {
+ insinto /usr/share/php/TheSeer/Tokenizer
+ doins -r src/*
+
+ einstalldocs
+}