summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-02-13 19:44:51 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-02-13 21:02:04 +0100
commit052b66de6c2e095baca23986e74c9f4fa91a88e3 (patch)
tree79df132fb7912b90d1d920bed2124fa4bf092ceb /dev-php/webmozart-assert/webmozart-assert-1.4.0.ebuild
parentdev-php/xdebug: bump to v2.7.0 RC1 (diff)
downloadgentoo-052b66de6c2e095baca23986e74c9f4fa91a88e3.tar.gz
gentoo-052b66de6c2e095baca23986e74c9f4fa91a88e3.tar.bz2
gentoo-052b66de6c2e095baca23986e74c9f4fa91a88e3.zip
dev-php/webmozart-assert: bump to v1.4.0
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/webmozart-assert/webmozart-assert-1.4.0.ebuild')
-rw-r--r--dev-php/webmozart-assert/webmozart-assert-1.4.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-php/webmozart-assert/webmozart-assert-1.4.0.ebuild b/dev-php/webmozart-assert/webmozart-assert-1.4.0.ebuild
new file mode 100644
index 000000000000..77df9aa06b41
--- /dev/null
+++ b/dev-php/webmozart-assert/webmozart-assert-1.4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PN="${PN/webmozart-//}"
+
+DESCRIPTION="Assertions to validate method input/output with nice error messages"
+HOMEPAGE="https://github.com/webmozart/assert"
+SRC_URI="https://github.com/webmozart/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-5.6:*"
+
+src_install() {
+ insinto /usr/share/php/Webmozart/Assert
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+}