summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-07-10 18:48:03 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-07-10 18:48:19 -0400
commit90d6b363a5e12a3de93aa91d77447344948147ce (patch)
tree6ae6fcd166e6a846dc87673a69d80b854b23f5f2 /dev-php/xcache
parentsys-devel/binutils-apple: Whitespace (diff)
downloadgentoo-90d6b363a5e12a3de93aa91d77447344948147ce.tar.gz
gentoo-90d6b363a5e12a3de93aa91d77447344948147ce.tar.bz2
gentoo-90d6b363a5e12a3de93aa91d77447344948147ce.zip
dev-php/xcache: new revision for v3.2.0.
The main reason for this revision is to make the coverager module optional. It is now hidden behind the USE=coverage flag and is not enabled by default (it is not recommended for production servers). At the same time, the ebuild was upgraded to EAPI=6 and now uses the newer revision php-ext-source-r3.eclass. Finally, the htdocs/ admin interface directory was moved out of /usr/share/php and into /usr/share/xcache, which is more appropriate. Two minor repoman warnings were also corrected. Gentoo-Bug: 491358 Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-php/xcache')
-rw-r--r--dev-php/xcache/metadata.xml7
-rw-r--r--dev-php/xcache/xcache-3.2.0-r1.ebuild64
-rw-r--r--dev-php/xcache/xcache-3.2.0.ebuild60
3 files changed, 71 insertions, 60 deletions
diff --git a/dev-php/xcache/metadata.xml b/dev-php/xcache/metadata.xml
index b86acf66c756..48b6cd35a6fc 100644
--- a/dev-php/xcache/metadata.xml
+++ b/dev-php/xcache/metadata.xml
@@ -5,4 +5,11 @@
<email>php-bugs@gentoo.org</email>
<name>PHP</name>
</maintainer>
+
+ <use>
+ <flag name="coverage">
+ Enable the coverager module (not recommended for
+ production servers).
+ </flag>
+ </use>
</pkgmetadata>
diff --git a/dev-php/xcache/xcache-3.2.0-r1.ebuild b/dev-php/xcache/xcache-3.2.0-r1.ebuild
new file mode 100644
index 000000000000..f6cd14d26263
--- /dev/null
+++ b/dev-php/xcache/xcache-3.2.0-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PHP_EXT_NAME="xcache"
+PHP_EXT_SAPIS="apache2 cgi fpm"
+USE_PHP="php5-5 php5-6"
+
+inherit php-ext-source-r3 confutils
+
+DESCRIPTION="A fast and stable PHP opcode cacher"
+HOMEPAGE="http://xcache.lighttpd.net/"
+SRC_URI="http://xcache.lighttpd.net/pub/Releases/${PV}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="coverage"
+
+# make test would just run php's test and as such need the full php source
+RESTRICT="test"
+
+DEPEND="
+ !dev-php/eaccelerator
+ !dev-php/pecl-apc
+ virtual/httpd-php:*
+ php_targets_php5-5? ( !dev-lang/php:5.5[opcache] )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS )
+
+src_configure() {
+ PHP_EXT_ECONF_ARGS=(
+ --enable-xcache=shared
+ --enable-xcache-constant \
+ --enable-xcache-optimizer \
+ $(use_enable coverage xcache-coverager) \
+ --enable-xcache-assembler \
+ --enable-xcache-encoder \
+ --enable-xcache-decoder )
+
+ php-ext-source-r3_src_configure
+}
+
+src_install() {
+ php-ext-source-r3_src_install
+
+ insinto "${PHP_EXT_SHARED_DIR}"
+ doins lib/Decompiler.class.php
+
+ # Install the admin interface somewhere where it can be
+ # copied/symlinked into a document root.
+ insinto "/usr/share/${PN}"
+ doins -r htdocs
+}
+
+pkg_postinst() {
+ elog "The lib/Decompiler.class.php file shipped with this release"
+ elog "was installed into ${PHP_EXT_SHARED_DIR}. The htdocs/ admin"
+ elog "interface directory can be found under ${EPREFIX}/usr/share/${PN}."
+}
diff --git a/dev-php/xcache/xcache-3.2.0.ebuild b/dev-php/xcache/xcache-3.2.0.ebuild
deleted file mode 100644
index 6ad537bdcb15..000000000000
--- a/dev-php/xcache/xcache-3.2.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-PHP_EXT_NAME="xcache"
-PHP_EXT_INI="yes"
-PHPSAPILIST="apache2 cgi fpm"
-USE_PHP="php5-4 php5-5 php5-6"
-
-inherit php-ext-source-r2 confutils
-
-DESCRIPTION="A fast and stable PHP opcode cacher"
-HOMEPAGE="http://xcache.lighttpd.net/"
-SRC_URI="http://xcache.lighttpd.net/pub/Releases/${PV}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-# make test would just run php's test and as such need the full php source
-RESTRICT="test"
-
-DEPEND="
- !dev-php/eaccelerator
- !dev-php/pecl-apc
- virtual/httpd-php
- php_targets_php5-5? ( !dev-lang/php:5.5[opcache] )
-"
-RDEPEND="${DEPEND}"
-
-src_configure() {
-
- my_conf="--enable-xcache=shared \
- --enable-xcache-constant \
- --enable-xcache-optimizer \
- --enable-xcache-coverager \
- --enable-xcache-assembler \
- --enable-xcache-encoder \
- --enable-xcache-decoder"
-
- php-ext-source-r2_src_configure
-}
-
-src_install() {
- php-ext-source-r2_src_install
- dodoc AUTHORS ChangeLog NEWS README THANKS
-
- insinto "${PHP_EXT_SHARED_DIR}"
- doins lib/Decompiler.class.php
- insinto "${PHP_EXT_SHARED_DIR}"
- doins -r htdocs
-}
-
-pkg_postinst() {
- elog "lib/Decompiler.class.php, and the htdocs/ directory shipped with this"
- elog "release were installed into ${PHP_EXT_SHARED_DIR}."
-}