summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-04-21 10:01:39 -0400
committerBrian Evans <grknight@gentoo.org>2017-04-21 10:01:39 -0400
commit6e534e02ec5a71c676dfbae1e9eb6041ef9316ab (patch)
treedf9d77de27c48e4f2ce818aa3887570e719d785d /dev-php/xdebug/xdebug-2.5.3.ebuild
parentdev-php/xdebug-client: Version bump to 2.5.3 (diff)
downloadgentoo-6e534e02ec5a71c676dfbae1e9eb6041ef9316ab.tar.gz
gentoo-6e534e02ec5a71c676dfbae1e9eb6041ef9316ab.tar.bz2
gentoo-6e534e02ec5a71c676dfbae1e9eb6041ef9316ab.zip
dev-php/xdebug: Version bump to 2.5.3
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-php/xdebug/xdebug-2.5.3.ebuild')
-rw-r--r--dev-php/xdebug/xdebug-2.5.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-php/xdebug/xdebug-2.5.3.ebuild b/dev-php/xdebug/xdebug-2.5.3.ebuild
new file mode 100644
index 000000000000..2f3ece25477e
--- /dev/null
+++ b/dev-php/xdebug/xdebug-2.5.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PHP_EXT_NAME="xdebug"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="yes"
+PHP_EXT_INIFILE="2.4.1-xdebug.ini"
+
+USE_PHP="php7-1 php7-0 php5-6"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+inherit php-ext-source-r3
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="A PHP debugging and profiling extension"
+HOMEPAGE="http://www.xdebug.org/"
+SRC_URI="http://pecl.php.net/get/${PN}-${MY_PV}.tgz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ ~dev-php/xdebug-client-${PV}"
+DOCS=( README.rst CREDITS )
+PHP_EXT_ECONF_ARGS=()
+
+pkg_postinst() {
+ ewarn "We have set xdebug.default_enable to 0 (off), as xdebug can be"
+ ewarn "installed as a dependency, and not all users will want xdebug to be"
+ ewarn "enabled by default. If you want to enable it, you should edit the"
+ ewarn "ini file and set xdebug.default_enable to 1. Alternatively you can"
+ ewarn "call xdebug_enable() in your code."
+}