summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-04-05 21:58:38 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-04-05 22:32:16 +0200
commit0599ee564853436a28258b21dfd325172ec57c84 (patch)
tree2503f7f310561ad182e4eaa9e933fdf4cdc4fc5c /dev-php
parentapp-eselect/eselect-repository: keyword ~riscv (diff)
downloadgentoo-0599ee564853436a28258b21dfd325172ec57c84.tar.gz
gentoo-0599ee564853436a28258b21dfd325172ec57c84.tar.bz2
gentoo-0599ee564853436a28258b21dfd325172ec57c84.zip
dev-php/PHPMailer: bump to v6.4.0
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PHPMailer/Manifest1
-rw-r--r--dev-php/PHPMailer/PHPMailer-6.4.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-php/PHPMailer/Manifest b/dev-php/PHPMailer/Manifest
index 8e8b7895b0cb..5460435db0b0 100644
--- a/dev-php/PHPMailer/Manifest
+++ b/dev-php/PHPMailer/Manifest
@@ -1,3 +1,4 @@
DIST PHPMailer-6.1.6.tar.gz 94769 BLAKE2B 6689f4429c0847de41016325553d58d544f78d5f8a94d9014841435a3cf161e4e10b14fe2cbb61c737bf75d87f2dc4cde66885c06a0b6992a472f0f46fe5dd6b SHA512 25530e6c5513e89729a5b253565143a5a9a35ee5f7813637eee18ca1d604cb83625f7beb106e56536f681d7ec4332fcd3cddcac5da7c73f730db1b056ba5b2e4
DIST PHPMailer-6.1.7.tar.gz 95102 BLAKE2B 8a1a09aa8f1c82900d881cf82e4a44705afbabc2f38b7bcf8b069a23c426f690dfbebd30c27a30dfbd8a3ad10e75e88fab4fa064bd44308b837455b84a41cad9 SHA512 4b37e11bb99966b8151b64a469125f249091c9b57ef729549735f37869fbaf1a1fb1a3f9d19822c824e909e8b53b696d3cb0d5180683e94968145a968622c2e8
DIST PHPMailer-6.2.0.tar.gz 95671 BLAKE2B e277f9a033e0b01381ac0a8d20b26d265b2ed187f0c9402a373bc2f9f526421830bd65d2ee11b061927963bcfea79ad8dd176c94ff58c41ccec8f80035a63afc SHA512 31a30e3ca3dd75bf36601870c272a12d6abdee09a9dc523f8ccc610f72a56789650e7a58990577929920b540552cbf75b83679d2cc5d9ce5efd3c214ce5baa42
+DIST PHPMailer-6.4.0.tar.gz 97758 BLAKE2B 5a06a72d457dbb3c8a4dab0debd549d13b023ce8ebbd8d089f3ff54fd671d8a3159da024d75cba9c25950f8aa19f2cdc1dd3b00ab03ca52a9c61e33ac214319c SHA512 488d7fc12683da9f1541ef2f237e255743eecca4162000c904e455255ba6a10dcf3aba004fb3efb0b3b37ac7dc35688f52731cd737fb3a9d1cdf53f9e48f90f1
diff --git a/dev-php/PHPMailer/PHPMailer-6.4.0.ebuild b/dev-php/PHPMailer/PHPMailer-6.4.0.ebuild
new file mode 100644
index 000000000000..48dc349297f3
--- /dev/null
+++ b/dev-php/PHPMailer/PHPMailer-6.4.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Full-featured email creation and transfer class for PHP"
+HOMEPAGE="https://github.com/PHPMailer/PHPMailer"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# To help out the Composer children, the tests and examples are missing
+# from the release tarballs.
+IUSE="doc idn ssl"
+
+# The ctype and filter extensions get used unconditionally, with no
+# fallback and no "extension missing" exception. All of the other
+# extensions are technically optional, depending on how you use
+# PHPMailer and whether or not you're willing to settle for fallback
+# implementations.
+#
+# The insane dependency string is to prevent the ctype and filter
+# extensions from being provided by one version (i.e. slot) of PHP,
+# while intl and unicode are provided by another.
+RDEPEND="
+ ssl? (
+ idn? ( dev-lang/php:*[ctype,filter,intl,ssl,unicode] )
+ !idn? ( dev-lang/php:*[ctype,filter,ssl] )
+ )
+ !ssl? (
+ idn? ( dev-lang/php:*[ctype,filter,intl,unicode] )
+ !idn? ( dev-lang/php:*[ctype,filter] )
+ )"
+BDEPEND="doc? ( dev-php/phpDocumentor )"
+
+src_prepare() {
+ default
+
+ # OAuth.php relies on a (now non-nonexistent) autoloader. We remove
+ # it early so that we don't generate documentation for it later on.
+ rm src/OAuth.php || die 'failed to remove src/OAuth.php'
+}
+
+src_compile() {
+ if use doc; then
+ phpdoc --filename="src/*.php" \
+ --target="./html" \
+ --cache-folder="${T}" \
+ --title="${PN}" \
+ --sourcecode \
+ --force \
+ --progressbar \
+ || die "failed to generate API documentation"
+ fi
+}
+
+src_install() {
+ # The PHPMailer class loads its language files
+ # using a relative path, so we need to keep the "src" here.
+ insinto "/usr/share/php/${PN}"
+ doins -r language src
+
+ dodoc README.md SECURITY.md
+ use doc && dodoc -r html/*
+}
+
+pkg_postinst() {
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog "Upstream no longer provides an autoloader, so you will need"
+ elog "to include each source file (for example: PHPMailer.php,"
+ elog "Exception.php,...) that you need."
+}