summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-08-27 14:24:13 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-08-27 15:16:03 +0200
commit15efeda80671b339913f283cec31ac93c097245d (patch)
tree1da05ad37a76590248e1f85b57c2618023fe4b9e /dev-php
parentmedia-video/pipewire: bump to v0.3.34 (diff)
downloadgentoo-15efeda80671b339913f283cec31ac93c097245d.tar.gz
gentoo-15efeda80671b339913f283cec31ac93c097245d.tar.bz2
gentoo-15efeda80671b339913f283cec31ac93c097245d.zip
dev-php/theseer-tokenizer: bump to v1.2.1
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/theseer-tokenizer/Manifest1
-rw-r--r--dev-php/theseer-tokenizer/theseer-tokenizer-1.2.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-php/theseer-tokenizer/Manifest b/dev-php/theseer-tokenizer/Manifest
index eb773bbb1aaa..82ec38ee8d33 100644
--- a/dev-php/theseer-tokenizer/Manifest
+++ b/dev-php/theseer-tokenizer/Manifest
@@ -1,3 +1,4 @@
DIST theseer-tokenizer-1.1.0.tar.gz 10163 BLAKE2B b2360f901d60f784db2045912707a8e293a55967d60d4e72168a1c4b0c9a2d5bdb739fbed9bfec02075476e7bf6762eb1cc7e36870b84fcc341b609527579ca2 SHA512 8b500565dc0d6c8513db3aa72a7ee1fa04510a712ce9b0977feccddc6b2dae53825e39182d43508e196f326776115789e81697116418f6f9f63d08f0c05d0543
DIST theseer-tokenizer-1.1.3.tar.gz 10553 BLAKE2B 4bed1623abe110cec432a97fbd28752618420a188b450c935c77b5771d6986be9a51c8f100fd81a89d892b0c1e2b46b0124e3c35e3cbe2138eee2d520c74933a SHA512 e29fd41b311bac8021f4c0593d79a9c1bde4b6ccf4774e94d27a0e8a97bac3844109f9312c4aab6e239365630394b602b56a084c291dc13fb439dc8ac22944e3
DIST theseer-tokenizer-1.2.0.tar.gz 7156 BLAKE2B 61474e3ebed5262b4d250f0057fbe68df6b2b2d6026cba28efbfc35c865bc9491e3b3f7871591a7aa52383c3bb748cf5dfb95f36d680bdbb9755b585b5b8f4f8 SHA512 e0deeffc151a1831cc7226037c75b534aa0d28d9639de45a1f0a6f5865d3df3cfbd7225e075b094603d512b0beb449e91205f40366ef1c7c865c8994e0710ff7
+DIST theseer-tokenizer-1.2.1.tar.gz 7537 BLAKE2B 204b39ca71cb6e99696c8bda19e5319e83302cd9fd4689343d3864ec81996d433ea8cfa2578abec2bef440271a1abe3169c3c871fd931c1ab73705cb7c36e4eb SHA512 7c7382f8f2e96984862d187fffb08b020cac8c0a0d93b58f9b1a244a46f8fcbfbe1c18d005acce8f8e1ef9aec2b9be99b7f2312e28f54a66f5a97ee263ed5239
diff --git a/dev-php/theseer-tokenizer/theseer-tokenizer-1.2.1.ebuild b/dev-php/theseer-tokenizer/theseer-tokenizer-1.2.1.ebuild
new file mode 100644
index 000000000000..2da5b5180736
--- /dev/null
+++ b/dev-php/theseer-tokenizer/theseer-tokenizer-1.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Convert tokenized PHP source code into XML and other formats"
+HOMEPAGE="https://github.com/theseer/tokenizer"
+SRC_URI="https://github.com/theseer/tokenizer/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+CDEPEND="dev-lang/php:*
+ dev-php/fedora-autoloader"
+
+BDEPEND="dev-php/theseer-Autoload"
+
+RDEPEND="${CDEPEND}"
+
+S="${WORKDIR}/tokenizer-${PV}"
+
+src_prepare() {
+ default
+
+ phpab \
+ --output src/autoload.php \
+ --template fedora2 \
+ --basedir src \
+ src || die
+}
+
+src_install() {
+ insinto /usr/share/php/TheSeer/Tokenizer
+ doins -r src/*
+
+ einstalldocs
+}