summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-11-29 14:23:37 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-11-29 14:23:37 +0100
commit18fe7bff51c86a2ae1930ef166b2994005242270 (patch)
tree9d5d9565cee7c17ddacb7df05b372447d7f2b9c4 /dev-php
parentdev-php/pecl-ps: add PHP 7.4 support (diff)
downloadgentoo-18fe7bff51c86a2ae1930ef166b2994005242270.tar.gz
gentoo-18fe7bff51c86a2ae1930ef166b2994005242270.tar.bz2
gentoo-18fe7bff51c86a2ae1930ef166b2994005242270.zip
dev-php/pecl-ps: fix tests
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-ps/pecl-ps-1.4.1.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-php/pecl-ps/pecl-ps-1.4.1.ebuild b/dev-php/pecl-ps/pecl-ps-1.4.1.ebuild
index 816c3d9eec8a..fd04378b47c9 100644
--- a/dev-php/pecl-ps/pecl-ps-1.4.1.ebuild
+++ b/dev-php/pecl-ps/pecl-ps-1.4.1.ebuild
@@ -40,3 +40,10 @@ src_install() {
php-ext-pecl-r3_src_install
fi
}
+
+src_test() {
+ if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
+ # tests/004.phpt depends on set numeric format
+ LC_ALL=C php-ext-pecl-r3_src_test
+ fi
+}