summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-03-09 10:37:33 -0500
committerBrian Evans <grknight@gentoo.org>2017-03-09 11:22:16 -0500
commit294a6d9202e9b03a1f55556523b9125803e3b420 (patch)
tree3fd6d97fac7bef11b64f5420d48492b020799383 /dev-php
parentdev-php/phpdocumentor-type-resolver: New package for an unbundled phpunit (diff)
downloadgentoo-294a6d9202e9b03a1f55556523b9125803e3b420.tar.gz
gentoo-294a6d9202e9b03a1f55556523b9125803e3b420.tar.bz2
gentoo-294a6d9202e9b03a1f55556523b9125803e3b420.zip
dev-php/phpdocumentor-reflection-docblock: New package for an unbundled phpunit
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/phpdocumentor-reflection-docblock/Manifest1
-rw-r--r--dev-php/phpdocumentor-reflection-docblock/files/autoload.php14
-rw-r--r--dev-php/phpdocumentor-reflection-docblock/metadata.xml8
-rw-r--r--dev-php/phpdocumentor-reflection-docblock/phpdocumentor-reflection-docblock-3.1.1.ebuild30
4 files changed, 53 insertions, 0 deletions
diff --git a/dev-php/phpdocumentor-reflection-docblock/Manifest b/dev-php/phpdocumentor-reflection-docblock/Manifest
new file mode 100644
index 000000000000..f4c26322b78f
--- /dev/null
+++ b/dev-php/phpdocumentor-reflection-docblock/Manifest
@@ -0,0 +1 @@
+DIST phpdocumentor-reflection-docblock-3.1.1.tar.gz 42935 SHA256 6139df076b13f7d8ea2c85f48690a05d2ba590cfd1ca1275febbd15e6ec990d1 SHA512 43f1824db3a7a3793db88817e3cedd6379c8e9074fac1a3e781d049a74a13bde3c519c0a9b2a9219d7869339ab16276229d5d3d9398d9bf7f6cdac6dea5a12d5 WHIRLPOOL be1ec5be4025cb1f7566738e974c7559f4d94d511fbf541222fa2cf7a2688b98d630ca5a927d8b1bbe79ba7f6b899208556a57160eac9f889b2f1fb4c587d096
diff --git a/dev-php/phpdocumentor-reflection-docblock/files/autoload.php b/dev-php/phpdocumentor-reflection-docblock/files/autoload.php
new file mode 100644
index 000000000000..70091f310ed1
--- /dev/null
+++ b/dev-php/phpdocumentor-reflection-docblock/files/autoload.php
@@ -0,0 +1,14 @@
+<?php
+/* Autoloader for dev-php/phpdocumentor-reflection-common */
+
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+}
+
+Fedora\Autoloader\Autoload::addPsr4('phpDocumentor\\Reflection\\', __DIR__);
+
+\Fedora\Autoloader\Dependencies::required(array(
+ '/usr/share/php/phpDocumentor/TypeResolver/autoload.php',
+ '/usr/share/php/phpDocumentor/ReflectionCommon/autoload.php',
+ '/usr/share/php/Webmozart/Assert/autoload.php',
+));
diff --git a/dev-php/phpdocumentor-reflection-docblock/metadata.xml b/dev-php/phpdocumentor-reflection-docblock/metadata.xml
new file mode 100644
index 000000000000..b86acf66c756
--- /dev/null
+++ b/dev-php/phpdocumentor-reflection-docblock/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-php/phpdocumentor-reflection-docblock/phpdocumentor-reflection-docblock-3.1.1.ebuild b/dev-php/phpdocumentor-reflection-docblock/phpdocumentor-reflection-docblock-3.1.1.ebuild
new file mode 100644
index 000000000000..0ee5e5f6d52c
--- /dev/null
+++ b/dev-php/phpdocumentor-reflection-docblock/phpdocumentor-reflection-docblock-3.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="ReflectionDocBlock"
+MY_VENDOR="phpDocumentor"
+
+DESCRIPTION="Provide support for annotations via DocBlocks"
+HOMEPAGE="https://www.phpdoc.org"
+SRC_URI="https://github.com/${MY_VENDOR}/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ <dev-php/phpdocumentor-reflection-common-2
+ <dev-php/phpdocumentor-type-resolver-1
+ <dev-php/webmozart-assert-2
+ >=dev-lang/php-5.6:*"
+
+src_install() {
+ insinto /usr/share/php/${MY_VENDOR}/${MY_PN}
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+}