summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2021-03-22 08:57:14 -0400
committerBrian Evans <grknight@gentoo.org>2021-03-22 08:57:14 -0400
commit353d2a156672c94d63678eb7523cdc766897fa8c (patch)
treeb1d8e9b53fb21e2ca06e75f180ffa660f48f6ebd /dev-php
parentapp-text/xchm: bump to 1.32 (diff)
downloadgentoo-353d2a156672c94d63678eb7523cdc766897fa8c.tar.gz
gentoo-353d2a156672c94d63678eb7523cdc766897fa8c.tar.bz2
gentoo-353d2a156672c94d63678eb7523cdc766897fa8c.zip
dev-php/PEAR-Exception: Version bump for 1.0.2
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-Exception/Manifest1
-rw-r--r--dev-php/PEAR-Exception/PEAR-Exception-1.0.2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-php/PEAR-Exception/Manifest b/dev-php/PEAR-Exception/Manifest
index 56d9fbc6fd89..b1265e4460fe 100644
--- a/dev-php/PEAR-Exception/Manifest
+++ b/dev-php/PEAR-Exception/Manifest
@@ -1 +1,2 @@
DIST PEAR_Exception-1.0.0.tgz 5270 BLAKE2B f6f6874083fcef2453e1d07e1ee3e900e4f7d18eca8e9a9eda9891492dd3fc1e31eb13944031e82044f976f1070463a3b099a8223d2dabb2da109bb123997f5a SHA512 f2078186fdad6c6ca59ac462a24f7f9689bea08d30f786acb7779d52cd433e490c752ba0a263067d869151b0c051cded327cb3477a039c5de68c854bff002b58
+DIST PEAR_Exception-1.0.2.tgz 5458 BLAKE2B f6e7bc452729ec4419650a0fbd6ef091dd5ec1b91804e1b59c598e44d3c04bf043084e385daa56fd1f6c012090010490922627a465061fe57ef9d74a49960e91 SHA512 80022c03bb665307a9feea88312301c86c903c5b8737559f59fc0028a08976976dd21e19a7dc805c27ec41f90ebd310012cd56ba2c2c006cf0df7cea69323a91
diff --git a/dev-php/PEAR-Exception/PEAR-Exception-1.0.2.ebuild b/dev-php/PEAR-Exception/PEAR-Exception-1.0.2.ebuild
new file mode 100644
index 000000000000..2a4a155c793d
--- /dev/null
+++ b/dev-php/PEAR-Exception/PEAR-Exception-1.0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/-/_}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="The PEAR Exception base class"
+HOMEPAGE="https://pear.php.net/package/PEAR_Exception"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND="dev-lang/php:*
+ !<=dev-php/PEAR-PEAR-1.10.3-r1"
+DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r PEAR
+}
+
+src_test() {
+ phpunit --do-not-cache-result tests || die "test suite failed"
+}