summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-02-09 19:37:38 +0100
committerThomas Deutschmann <whissi@gentoo.org>2021-02-09 19:43:54 +0100
commit375ef60f5c1c14fcf2bf24fdbf06b17f0de23d87 (patch)
tree86a012819e51014e9ca389e9be2a37fd06dd14fd /dev-php
parentdev-php/sebastian-object-reflector: bump to v2.0.4 (diff)
downloadgentoo-375ef60f5c1c14fcf2bf24fdbf06b17f0de23d87.tar.gz
gentoo-375ef60f5c1c14fcf2bf24fdbf06b17f0de23d87.tar.bz2
gentoo-375ef60f5c1c14fcf2bf24fdbf06b17f0de23d87.zip
dev-php/sebastian-type: bump to v1.1.4
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/sebastian-type/Manifest1
-rw-r--r--dev-php/sebastian-type/sebastian-type-1.1.4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-php/sebastian-type/Manifest b/dev-php/sebastian-type/Manifest
index 922b2aba2311..7435bb2e4050 100644
--- a/dev-php/sebastian-type/Manifest
+++ b/dev-php/sebastian-type/Manifest
@@ -1 +1,2 @@
DIST sebastian-type-1.1.3.tar.gz 19031 BLAKE2B 5e0d191cbc9315661f226aca14849ac4afa6d9e1dc59ca6033c60e425c94ee8b9ad49ab1c2b94c7814654bbadbaadd0164fadb1494f88c9521b2583985ba0281 SHA512 27b455c7a5f1125c916ea56fd933ef9ffa659b3fa6addf8d2c5956e4efef5bd8ffadc686e5dddfc50ba09a300c8148af7dded4249f404e15923e77102ab777fc
+DIST sebastian-type-1.1.4.tar.gz 19091 BLAKE2B 17a10d98c7356002b474ebab2c128631593ee175033fe9088a6fdfc29f020e33f1f090c1fb47c9890c686d41d207f5c8d2f6fffccd1e53341b8244b2633f55a1 SHA512 5320cad60dc79b213f30ec7b962d9e178ca7e49053eac040a50df3cea05579741f39bdc13872fb1b2d7c779a8e201767ee9550f47bb39cfca9fdac763886390d
diff --git a/dev-php/sebastian-type/sebastian-type-1.1.4.ebuild b/dev-php/sebastian-type/sebastian-type-1.1.4.ebuild
new file mode 100644
index 000000000000..2a0d5cf2d201
--- /dev/null
+++ b/dev-php/sebastian-type/sebastian-type-1.1.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/sebastian-/}"
+
+DESCRIPTION="Collection of value objects that represent the types of the PHP type system"
+HOMEPAGE="https://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+BDEPEND="dev-php/theseer-Autoload"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-7.2:*"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ default
+
+ phpab \
+ --output src/autoload.php \
+ --template fedora2 \
+ --basedir src \
+ src \
+ || die
+}
+
+src_install() {
+ insinto /usr/share/php/SebastianBergmann/Type
+ doins -r src/.
+
+ einstalldocs
+}