summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2020-02-21 12:48:13 -0500
committerBrian Evans <grknight@gentoo.org>2020-02-21 12:48:13 -0500
commit386ca68d84816e17d239d56c7d03303d0d3ae059 (patch)
tree3bae411031db2abd960b87c6715e6e01188052da /dev-php
parentdev-php/xhprof: Version bump for 2.1.4 (diff)
downloadgentoo-386ca68d84816e17d239d56c7d03303d0d3ae059.tar.gz
gentoo-386ca68d84816e17d239d56c7d03303d0d3ae059.tar.bz2
gentoo-386ca68d84816e17d239d56c7d03303d0d3ae059.zip
dev-php/pecl-stomp: Revbump for EAPI and target changes
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-stomp/pecl-stomp-2.0.2-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-php/pecl-stomp/pecl-stomp-2.0.2-r1.ebuild b/dev-php/pecl-stomp/pecl-stomp-2.0.2-r1.ebuild
new file mode 100644
index 000000000000..bc5c1a2e4ad0
--- /dev/null
+++ b/dev-php/pecl-stomp/pecl-stomp-2.0.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_PHP="php7-2 php7-3 php7-4"
+PHP_EXT_NAME="stomp"
+PHP_EXT_NEEDED_USE="ssl(-)?"
+DOCS=( CREDITS doc/classes.php doc/functions.php )
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP extension to communicate with Stomp message brokers"
+LICENSE="PHP-3.01"
+SLOT="7"
+IUSE="examples ssl test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-stomp
+ --with-openssl-dir=$(usex ssl yes no)
+ )
+ php-ext-source-r3_src_configure
+}