summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-01-17 14:31:16 -0500
committerMichael Orlitzky <mjo@gentoo.org>2017-01-17 14:31:16 -0500
commit4d5b3affd5abc85ab3f2873fcaf53301d6f263de (patch)
treed0a36c1e6dc8e024af20faf943a18569ab950d19 /dev-php
parentdev-php/pecl-rrd: new EAPI=6 revisions. (diff)
downloadgentoo-4d5b3affd5abc85ab3f2873fcaf53301d6f263de.tar.gz
gentoo-4d5b3affd5abc85ab3f2873fcaf53301d6f263de.tar.bz2
gentoo-4d5b3affd5abc85ab3f2873fcaf53301d6f263de.zip
dev-php/xdebug: remove unused xdebug-2.2.6.
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/xdebug/Manifest1
-rw-r--r--dev-php/xdebug/xdebug-2.2.6.ebuild89
2 files changed, 0 insertions, 90 deletions
diff --git a/dev-php/xdebug/Manifest b/dev-php/xdebug/Manifest
index eee7c235c2e6..2326ca86e3c3 100644
--- a/dev-php/xdebug/Manifest
+++ b/dev-php/xdebug/Manifest
@@ -1,3 +1,2 @@
-DIST xdebug-2.2.6.tgz 256161 SHA256 6dd1cba0605e75009331aa3625a19ef49ade5a75aa9fe2ff8a818108d2cce84e SHA512 18deac94f8f9c102dce83ed1accd0831e5b8c2f5d47ea60f89c8b493e5e180d0dfa153065089e1081276db8960ff2ea4082103f228f9191c572888180efa6f82 WHIRLPOOL 0e152ea5740bc8ca8cc6d0178bb59556f98ba0722a0b3cdaeecdc5aa551324cadf5f1c11b215058cf890c16eb7e9e108919a389a6c89d60a469396a20cc083ed
DIST xdebug-2.4.1.tgz 265542 SHA256 23c8786e0f5aae67b1e5035972bfff282710fb84c483887cebceb8ef5bbdf8ef SHA512 64b345b4809fb0f020eb8fe7a0826056a64728ec9565bbb2d0e717ac7b3ca8aa0856b91c2ba47a7435b7500c5efa643682f245d6cd9d0a537f8bb9ab0d5cea3a WHIRLPOOL cad7d081414d5a55fb95e4cb6ae5d808f5c6b54e1c16ba78274fadf9b32dd10e60ecab3d09d420462b7c95f7d9364d9f886fe7732a21284c635e70c24259a610
DIST xdebug-2.5.0.tgz 267640 SHA256 8bd6ad1e64948308e3e3a7437292f154b11e25acaf31b0d59d83bda18af0890d SHA512 75b1dbf32059eebb6ea3fb6ebb50ab26d73f8ce2964be1fec41ecfd9ae3d8bd55b6997daf03727b28b91ba06d08734865158bed6f038a46f00a1da5424ce5fe6 WHIRLPOOL 01901c73cf6d4ca8803a21eee8e1b5fcc668de75f0cb4318f6637a2d3a93e050664ee4dfa03ec0281e154e1e7660dc084b1b75c4b0451e1b4bab3db5ff00ea71
diff --git a/dev-php/xdebug/xdebug-2.2.6.ebuild b/dev-php/xdebug/xdebug-2.2.6.ebuild
deleted file mode 100644
index a77b2c198167..000000000000
--- a/dev-php/xdebug/xdebug-2.2.6.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-PHP_EXT_NAME="xdebug"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="yes"
-
-USE_PHP="php5-6 php5-5 php5-4"
-
-MY_PV="${PV/_/}"
-MY_PV="${MY_PV/rc/RC}"
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-inherit php-ext-source-r2
-
-KEYWORDS="amd64 ~hppa ppc ppc64 x86"
-
-DESCRIPTION="A PHP debugging and profiling extension"
-HOMEPAGE="http://www.xdebug.org/"
-SRC_URI="http://pecl.php.net/get/${PN}-${MY_PV}.tgz"
-LICENSE="Xdebug"
-SLOT="0"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}
- ~dev-php/xdebug-client-${PV}"
-
-src_install() {
- dodoc NEWS README CREDITS
- php-ext-source-r2_src_install
-
- php-ext-source-r2_addtoinifiles "xdebug.auto_trace" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.trace_output_dir" '"/tmp"'
- php-ext-source-r2_addtoinifiles "xdebug.trace_output_name" '"trace.%c"'
- php-ext-source-r2_addtoinifiles "xdebug.trace_format" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.trace_options" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.collect_includes" '"1"'
- php-ext-source-r2_addtoinifiles "xdebug.collect_params" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.collect_return" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.collect_vars" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.default_enable" '"1"'
- php-ext-source-r2_addtoinifiles "xdebug.extended_info" '"1"'
- php-ext-source-r2_addtoinifiles "xdebug.manual_url" '"http://www.php.net"'
- php-ext-source-r2_addtoinifiles "xdebug.max_nesting_level" '"100"'
- php-ext-source-r2_addtoinifiles "xdebug.show_exception_trace" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.show_local_vars" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.show_mem_delta" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.dump.COOKIE" '"NULL"'
- php-ext-source-r2_addtoinifiles "xdebug.dump.ENV" '"NULL"'
- php-ext-source-r2_addtoinifiles "xdebug.dump.FILES" '"NULL"'
- php-ext-source-r2_addtoinifiles "xdebug.dump.GET" '"NULL"'
- php-ext-source-r2_addtoinifiles "xdebug.dump.POST" '"NULL"'
- php-ext-source-r2_addtoinifiles "xdebug.dump.REQUEST" '"NULL"'
- php-ext-source-r2_addtoinifiles "xdebug.dump.SERVER" '"NULL"'
- php-ext-source-r2_addtoinifiles "xdebug.dump.SESSION" '"NULL"'
- php-ext-source-r2_addtoinifiles "xdebug.dump_globals" '"1"'
- php-ext-source-r2_addtoinifiles "xdebug.dump_once" '"1"'
- php-ext-source-r2_addtoinifiles "xdebug.dump_undefined" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.profiler_enable" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.profiler_output_dir" '"/tmp"'
- php-ext-source-r2_addtoinifiles "xdebug.profiler_output_name" '"cachegrind.out.%p"'
- php-ext-source-r2_addtoinifiles "xdebug.profiler_enable_trigger" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.profiler_append" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.profiler_aggregate" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.remote_enable" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.remote_handler" '"dbgp"'
- php-ext-source-r2_addtoinifiles "xdebug.remote_host" '"localhost"'
- php-ext-source-r2_addtoinifiles "xdebug.remote_mode" '"req"'
- php-ext-source-r2_addtoinifiles "xdebug.remote_port" '"9000"'
- php-ext-source-r2_addtoinifiles "xdebug.remote_autostart" '"0"'
- php-ext-source-r2_addtoinifiles "xdebug.remote_log" '""'
- php-ext-source-r2_addtoinifiles "xdebug.idekey" '""'
- php-ext-source-r2_addtoinifiles "xdebug.var_display_max_data" '"512"'
- php-ext-source-r2_addtoinifiles "xdebug.var_display_max_depth" '"2"'
- php-ext-source-r2_addtoinifiles "xdebug.var_display_max_children" '"128"'
-
-}
-
-pkg_postinst() {
- ewarn "We have set xdebug.default_enable to 0 (off), as xdebug can be"
- ewarn "installed as a dependency, and not all users will want xdebug to be"
- ewarn "enabled by default. If you want to enable it, you should edit the"
- ewarn "ini file and set xdebug.default_enable to 1. Alternatively you can"
- ewarn "call xdebug_enable() in your code."
-}