summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-04-23 09:35:32 -0400
committerBrian Evans <grknight@gentoo.org>2018-04-23 09:58:57 -0400
commit5710733ee395c689fabbd7b57bc69070bcd34172 (patch)
treefcb77f530394c4394a3facf5773ea44067130fbd /dev-php
parentdev-php/PEAR-Cache_Lite: Drop old (diff)
downloadgentoo-5710733ee395c689fabbd7b57bc69070bcd34172.tar.gz
gentoo-5710733ee395c689fabbd7b57bc69070bcd34172.tar.bz2
gentoo-5710733ee395c689fabbd7b57bc69070bcd34172.zip
dev-php/PEAR-Config: Revbump to fix tests
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-Config/PEAR-Config-2.0.0_pre20140323-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-php/PEAR-Config/PEAR-Config-2.0.0_pre20140323-r1.ebuild b/dev-php/PEAR-Config/PEAR-Config-2.0.0_pre20140323-r1.ebuild
new file mode 100644
index 000000000000..fd949ea89cfc
--- /dev/null
+++ b/dev-php/PEAR-Config/PEAR-Config-2.0.0_pre20140323-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2 vcs-snapshot
+
+DESCRIPTION="Provides multiple methods for configuration manipulation"
+LICENSE="PHP-2.02"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test xml"
+RDEPEND="xml? ( dev-php/PEAR-XML_Parser dev-php/PEAR-XML_Util )"
+DEPEND="test? ( ${RDEPEND} )"
+SRC_URI="https://github.com/pear/Config/archive/606a24034ad80f9d6ccb5a8b698b702b392e4674.tar.gz -> ${PEAR_P}.tar.gz"
+DOCS=( docs/TODO )
+HTML_DOCS=( docs/Apache.php docs/IniCommented.php docs/IniFromScratch.php )
+
+src_prepare() {
+ # Move snapshot location to where the eclass expects
+ mv "${S}/package.xml" "${WORKDIR}/package.xml" || die
+ sed -i 's/&new/new/' test/phpt_test.php.inc || die
+ sed -i 's/& new/ new/' test/bug6441.phpt || die
+ eapply_user
+}
+
+src_test() {
+ pear run-tests test || die "Tests failed"
+}