summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-07-28 10:09:48 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-07-28 10:37:46 -0400
commit58dfcd33e7bf173be4e0f34e259ebd153fa69ccf (patch)
treeabe4c28a498511de78fb32168dbe708d327f27ce /dev-php
parentdev-php/PEAR-Archive_Tar: new revision to clean up dependencies. (diff)
downloadgentoo-58dfcd33e7bf173be4e0f34e259ebd153fa69ccf.tar.gz
gentoo-58dfcd33e7bf173be4e0f34e259ebd153fa69ccf.tar.bz2
gentoo-58dfcd33e7bf173be4e0f34e259ebd153fa69ccf.zip
dev-php/PEAR-Console_Getopt: new revision to clean up dependencies.
This package had a build-time dependency on dev-lang/php that was intended to be a runtime dependency; now fixed. There were also redundant dependencies on dev-php/pear and dev-php/PEAR-PEAR (which are the same, for all intents and purposes). The dev-php/pear dependency has been removed in favor of a single PDEPEND on dev-php/PEAR-PEAR. Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.4.1-r1.ebuild (renamed from dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.4.1.ebuild)19
1 files changed, 9 insertions, 10 deletions
diff --git a/dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.4.1.ebuild b/dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.4.1-r1.ebuild
index d2487e44f01f..3924f36c3b05 100644
--- a/dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.4.1.ebuild
+++ b/dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.4.1-r1.ebuild
@@ -1,28 +1,27 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
MY_PN="${PN/PEAR-/}"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Command-line option parser"
-
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://pear.php.net/get/${MY_P}.tgz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE=""
-SRC_URI="http://pear.php.net/get/${MY_P}.tgz"
-DEPEND=">=dev-lang/php-5.4:*
- >=dev-php/PEAR-PEAR-1.8.1"
-RDEPEND="${DEPEND}"
-PDEPEND="dev-php/pear"
-HOMEPAGE="http://pear.php.net/package/Console_Getopt"
+
+DEPEND=""
+RDEPEND="dev-lang/php:*"
+PDEPEND="dev-php/PEAR-PEAR"
S="${WORKDIR}/${MY_P}"
src_install() {
- insinto /usr/share/php/
+ insinto /usr/share/php
doins -r Console
}