summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-07-18 14:15:51 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-07-18 15:01:18 +0200
commit5c00ed46ed162bb9c1c2467827b1347da2349a2b (patch)
tree70bf7123aba8012edf857040c3b94d3ee19f1a9e /dev-php
parentapp-doc/gnucash-docs: Sanitize L10N handling (diff)
downloadgentoo-5c00ed46ed162bb9c1c2467827b1347da2349a2b.tar.gz
gentoo-5c00ed46ed162bb9c1c2467827b1347da2349a2b.tar.bz2
gentoo-5c00ed46ed162bb9c1c2467827b1347da2349a2b.zip
dev-php/composer: bump to v1.8.6
Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/composer/Manifest1
-rw-r--r--dev-php/composer/composer-1.8.6.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-php/composer/Manifest b/dev-php/composer/Manifest
index bfbb92bdd007..1f0adaeaa3f2 100644
--- a/dev-php/composer/Manifest
+++ b/dev-php/composer/Manifest
@@ -5,3 +5,4 @@ DIST composer-1.7.3.tar.gz 402233 BLAKE2B b9ae601e5710f12acd6da189a64217fee0198a
DIST composer-1.8.0.tar.gz 404169 BLAKE2B 977d04d3477e0660eb33e4cb746a5f7cf1cc15544b0afdc48ce7dc7774750b685c36db7796280dd825e2b5b5d310f65521a6c12ca92ca9d2b15c2213c64bec4f SHA512 d8589c75174fd36f5ce10c8f4e18045b8c86167ccc7d6cadb4eed8828d4d7b4b44b0b477b6bd0ebf6d0981a381b35f662205d6b4324c92c86ea3fbc8c3aeb6e4
DIST composer-1.8.3.tar.gz 405927 BLAKE2B 00be1624fb96212edffd7059b718e74ed69643810de2ddfd6ffa1fb16ac689d2298d420452e7461bb427cc2e8186f4d2c9be072054fe7310bc74c32b80a1a497 SHA512 bb3ddcddcd30c211deae5a75fdfb178c39f0714efd59cb2a4abebdcdc9e18cf9437cae26ed21881fe06278472c150de2935f70b48c3f3c5d7e2a1ea92ee26605
DIST composer-1.8.4.tar.gz 406561 BLAKE2B 2521da6a50371102c2a8bf61aeeba0c5846692dcbaaa13e83d09a42480c518f91889bd6d6461aef60958d1f68801f77a646c7940c5992a8da25adf050550050b SHA512 b1061fd190b05d2fc309ff76bf246f6d02547249fe52c347715c2dc2e4f5149b3c4e4f43f255874749caeb44ce05cfcbdb8da1d96a9f88a2213a9601e123ef9c
+DIST composer-1.8.6.tar.gz 409002 BLAKE2B 15d9621e062646b81518aff816a3e0b187bf1d9cd617c32e3a19167ba0c89b9ee8f55503e7d2e6d3515939f7d50131c5be0786fc04518409584960290eb32118 SHA512 97ab93acba24307897fe64b3762e77ebca9fa794c5eb476a9d774feb124dbd53b090c36b0fa9d1da38ea26d13af8bf13d7bc733c9c465fba6b908e590ea96dbc
diff --git a/dev-php/composer/composer-1.8.6.ebuild b/dev-php/composer/composer-1.8.6.ebuild
new file mode 100644
index 000000000000..2c139b8b8825
--- /dev/null
+++ b/dev-php/composer/composer-1.8.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Dependency Manager for PHP"
+HOMEPAGE="https://github.com/composer/composer"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-lang/php:*[curl]
+ >=dev-php/ca-bundle-1.1.3
+ >=dev-php/psr-log-1.1.0
+ dev-php/fedora-autoloader
+ >=dev-php/json-schema-5.2.7
+ >=dev-php/jsonlint-1.7.1
+ >=dev-php/phar-utils-1.0.1
+ >=dev-php/semver-1.4.2
+ >=dev-php/spdx-licenses-1.5.0
+ >=dev-php/symfony-console-2.8.48
+ >=dev-php/symfony-filesystem-2.8.48
+ >=dev-php/symfony-finder-2.8.49
+ >=dev-php/symfony-process-2.8.48
+ >=dev-php/xdebug-handler-1.3.1"
+
+src_install() {
+ insinto "/usr/share/${PN}"
+
+ # Composer expects the LICENSE file to be there, and the
+ # easiest thing to do is to give it what it wants.
+ doins -r src res LICENSE
+
+ insinto "/usr/share/${PN}/vendor"
+ newins "${FILESDIR}"/autoload-r1.php autoload.php
+
+ exeinto "/usr/share/${PN}/bin"
+ doexe "bin/${PN}"
+ dosym "../share/${PN}/bin/${PN}" "/usr/bin/${PN}"
+
+ dodoc CHANGELOG.md README.md doc/*.md
+ dodoc -r doc/articles doc/faqs
+}