summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-02-02 01:45:52 +0100
committerThomas Deutschmann <whissi@gentoo.org>2021-02-02 02:17:52 +0100
commit6330e67889ff6fa8be256b7f0f463a7133e720fb (patch)
tree4a5a0dfc1133a12193dee8314cecbeebb9ceb6d4 /dev-php
parentdev-php/doctrine-instantiator: bump to v1.4.0 (diff)
downloadgentoo-6330e67889ff6fa8be256b7f0f463a7133e720fb.tar.gz
gentoo-6330e67889ff6fa8be256b7f0f463a7133e720fb.tar.bz2
gentoo-6330e67889ff6fa8be256b7f0f463a7133e720fb.zip
dev-php/jsonlint: bump to v1.8.3
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/jsonlint/Manifest1
-rw-r--r--dev-php/jsonlint/jsonlint-1.8.3.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-php/jsonlint/Manifest b/dev-php/jsonlint/Manifest
index 02c9af5eda49..897e3a361588 100644
--- a/dev-php/jsonlint/Manifest
+++ b/dev-php/jsonlint/Manifest
@@ -1 +1,2 @@
DIST jsonlint-1.8.2.tar.gz 13729 BLAKE2B 80cbe2e1dc6bcbc0d75d04f34a36deb8b53ebd78bc4dcff0dd1195549ae2eaa02360b642d91c6a848cba9a3f502ed0618937c149663d6d0c9c7ad0f33897b7c1 SHA512 675ae7bf6cddd83bb2fab60f4c2ac4a8b4bf0068e630f266511a1805682cadefc9a44006623448364ceb73c5e211739787643d9196794349b992cca4d5fc737c
+DIST jsonlint-1.8.3.tar.gz 10588 BLAKE2B af54e4bedb66e28f61c338f5161109cf1df45dc4aea7c5ab27d728aa4ca6cc0c1e76575527abffc0a1ff8b52465cee40935829f71b3b1a0284c0512827b5bc3c SHA512 c2a9a16e9abc048a1899e51cc78995410b8aa44d5afdab30930f7a7d88b174844ac0f547b0d0da83bc4a71ca0457392e586afbc97cef5de36e0dc2e032732bfc
diff --git a/dev-php/jsonlint/jsonlint-1.8.3.ebuild b/dev-php/jsonlint/jsonlint-1.8.3.ebuild
new file mode 100644
index 000000000000..5882c9617f68
--- /dev/null
+++ b/dev-php/jsonlint/jsonlint-1.8.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="JSON Lint for PHP"
+HOMEPAGE="https://github.com/Seldaek/jsonlint"
+SRC_URI="https://github.com/Seldaek/jsonlint/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="dev-php/theseer-Autoload"
+
+RDEPEND="dev-php/fedora-autoloader
+ dev-lang/php:*"
+
+src_prepare() {
+ default
+
+ phpab \
+ --output src/Seld/JsonLint/autoload.php \
+ --template fedora2 \
+ --basedir src \
+ src \
+ || die
+}
+
+src_install() {
+ insinto "/usr/share/php/Seld/JsonLint"
+ doins -r src/Seld/JsonLint/.
+
+ einstalldocs
+}