summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2021-02-25 14:15:32 -0500
committerBrian Evans <grknight@gentoo.org>2021-02-25 14:16:00 -0500
commit72e5ae4c43f214bcc7377ebe32c3c38162e34a20 (patch)
treeeee04a6ccf98cf60b29060ce1d45b41b4b4eb0b6 /dev-php
parentdev-lang/php: Drop end-of-life 7.2 slot (diff)
downloadgentoo-72e5ae4c43f214bcc7377ebe32c3c38162e34a20.tar.gz
gentoo-72e5ae4c43f214bcc7377ebe32c3c38162e34a20.tar.bz2
gentoo-72e5ae4c43f214bcc7377ebe32c3c38162e34a20.zip
dev-php/phpunit: Drop old version
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/phpunit/Manifest1
-rw-r--r--dev-php/phpunit/files/autoload.php170
-rw-r--r--dev-php/phpunit/phpunit-5.7.15-r3.ebuild53
3 files changed, 0 insertions, 224 deletions
diff --git a/dev-php/phpunit/Manifest b/dev-php/phpunit/Manifest
index 29e15afff8a7..31d7859aad6e 100644
--- a/dev-php/phpunit/Manifest
+++ b/dev-php/phpunit/Manifest
@@ -1,3 +1,2 @@
-DIST phpunit-5.7.15.tar.gz 205474 BLAKE2B 0220edd59fc3f191b7621f275d3e4ee8f8bf514f74533d99bfb925e11cc54a235fb292ffd1bb54f6bec1e038c06e35a0dc43c1227618590f99e7e85638a7de28 SHA512 6a836e1ad1656fd1d1c5a58ced3c1826b4decc01798b6a804b487c9b4e094ec32f6eb8a84058e268eade62a2fe19d7bd1e760b8b9433299d9fe9c09afdf2bdd3
DIST phpunit-8.5.11.tar.gz 159302 BLAKE2B fdf156842b3607f4cbd26194efd7eb7cb204fb1d1d078c0c6bd3bb68e520e5d748767f8aab64b7c9bf313161e3d84e08d415fbf0408c26541ec1f70cfe7af8bd SHA512 3e9db4a1d6c5bea3546b24bd837479a0114a9200f96034aabc96933dfb42c1237b03f7118f19eeb1216e32f2034c1ec8c632d20ecacbe70d3660fbbfd167ac79
DIST phpunit-8.5.14.tar.gz 163158 BLAKE2B 8be0765b89cd7c7f91c7c8753eda9be46a38368c1b538b9e1a06b6f7e5b2cf2c37ef806338b7f4dd213962bfb8f7d749e1a97dd65d0e877fb2ffdeb747dcd344 SHA512 589cd74bf44c16ee0bb0b0e85f3468b0fdbd7e6ce968894954918094d49a0fed46570cac2fa2367f417715bf64f942f5742a292b09edd91317bbea06624ac313
diff --git a/dev-php/phpunit/files/autoload.php b/dev-php/phpunit/files/autoload.php
deleted file mode 100644
index f33b4c8881a1..000000000000
--- a/dev-php/phpunit/files/autoload.php
+++ /dev/null
@@ -1,170 +0,0 @@
-<?php
-/* Autoloader for dev-php/phpunit and its dependencies */
-
-$include_dir = '/usr/share/php';
-
-if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
- require_once "${include_dir}/Fedora/Autoloader/autoload.php";
-}
-
-\Fedora\Autoloader\Autoload::addClassMap(
- array(
- 'phpunit\\framework\\assert' => '/ForwardCompatibility/Assert.php',
- 'phpunit\\framework\\basetestlistener' => '/ForwardCompatibility/BaseTestListener.php',
- 'phpunit\\framework\\testcase' => '/ForwardCompatibility/TestCase.php',
- 'phpunit\\framework\\testlistener' => '/ForwardCompatibility/TestListener.php',
- 'phpunit_exception' => '/Exception.php',
- 'phpunit_extensions_grouptestsuite' => '/Extensions/GroupTestSuite.php',
- 'phpunit_extensions_phpttestcase' => '/Extensions/PhptTestCase.php',
- 'phpunit_extensions_phpttestsuite' => '/Extensions/PhptTestSuite.php',
- 'phpunit_extensions_repeatedtest' => '/Extensions/RepeatedTest.php',
- 'phpunit_extensions_testdecorator' => '/Extensions/TestDecorator.php',
- 'phpunit_extensions_ticketlistener' => '/Extensions/TicketListener.php',
- 'phpunit_framework_assert' => '/Framework/Assert.php',
- 'phpunit_framework_assertionfailederror' => '/Framework/AssertionFailedError.php',
- 'phpunit_framework_basetestlistener' => '/Framework/BaseTestListener.php',
- 'phpunit_framework_codecoverageexception' => '/Framework/CodeCoverageException.php',
- 'phpunit_framework_constraint' => '/Framework/Constraint.php',
- 'phpunit_framework_constraint_and' => '/Framework/Constraint/And.php',
- 'phpunit_framework_constraint_arrayhaskey' => '/Framework/Constraint/ArrayHasKey.php',
- 'phpunit_framework_constraint_arraysubset' => '/Framework/Constraint/ArraySubset.php',
- 'phpunit_framework_constraint_attribute' => '/Framework/Constraint/Attribute.php',
- 'phpunit_framework_constraint_callback' => '/Framework/Constraint/Callback.php',
- 'phpunit_framework_constraint_classhasattribute' => '/Framework/Constraint/ClassHasAttribute.php',
- 'phpunit_framework_constraint_classhasstaticattribute' => '/Framework/Constraint/ClassHasStaticAttribute.php',
- 'phpunit_framework_constraint_composite' => '/Framework/Constraint/Composite.php',
- 'phpunit_framework_constraint_count' => '/Framework/Constraint/Count.php',
- 'phpunit_framework_constraint_directoryexists' => '/Framework/Constraint/DirectoryExists.php',
- 'phpunit_framework_constraint_exception' => '/Framework/Constraint/Exception.php',
- 'phpunit_framework_constraint_exceptioncode' => '/Framework/Constraint/ExceptionCode.php',
- 'phpunit_framework_constraint_exceptionmessage' => '/Framework/Constraint/ExceptionMessage.php',
- 'phpunit_framework_constraint_exceptionmessageregexp' => '/Framework/Constraint/ExceptionMessageRegExp.php',
- 'phpunit_framework_constraint_fileexists' => '/Framework/Constraint/FileExists.php',
- 'phpunit_framework_constraint_greaterthan' => '/Framework/Constraint/GreaterThan.php',
- 'phpunit_framework_constraint_isanything' => '/Framework/Constraint/IsAnything.php',
- 'phpunit_framework_constraint_isempty' => '/Framework/Constraint/IsEmpty.php',
- 'phpunit_framework_constraint_isequal' => '/Framework/Constraint/IsEqual.php',
- 'phpunit_framework_constraint_isfalse' => '/Framework/Constraint/IsFalse.php',
- 'phpunit_framework_constraint_isfinite' => '/Framework/Constraint/IsFinite.php',
- 'phpunit_framework_constraint_isidentical' => '/Framework/Constraint/IsIdentical.php',
- 'phpunit_framework_constraint_isinfinite' => '/Framework/Constraint/IsInfinite.php',
- 'phpunit_framework_constraint_isinstanceof' => '/Framework/Constraint/IsInstanceOf.php',
- 'phpunit_framework_constraint_isjson' => '/Framework/Constraint/IsJson.php',
- 'phpunit_framework_constraint_isnan' => '/Framework/Constraint/IsNan.php',
- 'phpunit_framework_constraint_isnull' => '/Framework/Constraint/IsNull.php',
- 'phpunit_framework_constraint_isreadable' => '/Framework/Constraint/IsReadable.php',
- 'phpunit_framework_constraint_istrue' => '/Framework/Constraint/IsTrue.php',
- 'phpunit_framework_constraint_istype' => '/Framework/Constraint/IsType.php',
- 'phpunit_framework_constraint_iswritable' => '/Framework/Constraint/IsWritable.php',
- 'phpunit_framework_constraint_jsonmatches' => '/Framework/Constraint/JsonMatches.php',
- 'phpunit_framework_constraint_jsonmatches_errormessageprovider' => '/Framework/Constraint/JsonMatches/ErrorMessageProvider.php',
- 'phpunit_framework_constraint_lessthan' => '/Framework/Constraint/LessThan.php',
- 'phpunit_framework_constraint_not' => '/Framework/Constraint/Not.php',
- 'phpunit_framework_constraint_objecthasattribute' => '/Framework/Constraint/ObjectHasAttribute.php',
- 'phpunit_framework_constraint_or' => '/Framework/Constraint/Or.php',
- 'phpunit_framework_constraint_pcrematch' => '/Framework/Constraint/PCREMatch.php',
- 'phpunit_framework_constraint_samesize' => '/Framework/Constraint/SameSize.php',
- 'phpunit_framework_constraint_stringcontains' => '/Framework/Constraint/StringContains.php',
- 'phpunit_framework_constraint_stringendswith' => '/Framework/Constraint/StringEndsWith.php',
- 'phpunit_framework_constraint_stringmatches' => '/Framework/Constraint/StringMatches.php',
- 'phpunit_framework_constraint_stringstartswith' => '/Framework/Constraint/StringStartsWith.php',
- 'phpunit_framework_constraint_traversablecontains' => '/Framework/Constraint/TraversableContains.php',
- 'phpunit_framework_constraint_traversablecontainsonly' => '/Framework/Constraint/TraversableContainsOnly.php',
- 'phpunit_framework_constraint_xor' => '/Framework/Constraint/Xor.php',
- 'phpunit_framework_coveredcodenotexecutedexception' => '/Framework/CoveredCodeNotExecutedException.php',
- 'phpunit_framework_error' => '/Framework/Error.php',
- 'phpunit_framework_error_deprecated' => '/Framework/Error/Deprecated.php',
- 'phpunit_framework_error_notice' => '/Framework/Error/Notice.php',
- 'phpunit_framework_error_warning' => '/Framework/Error/Warning.php',
- 'phpunit_framework_exception' => '/Framework/Exception.php',
- 'phpunit_framework_exceptionwrapper' => '/Framework/ExceptionWrapper.php',
- 'phpunit_framework_expectationfailedexception' => '/Framework/ExpectationFailedException.php',
- 'phpunit_framework_incompletetest' => '/Framework/IncompleteTest.php',
- 'phpunit_framework_incompletetestcase' => '/Framework/IncompleteTestCase.php',
- 'phpunit_framework_incompletetesterror' => '/Framework/IncompleteTestError.php',
- 'phpunit_framework_invalidcoverstargetexception' => '/Framework/InvalidCoversTargetException.php',
- 'phpunit_framework_missingcoversannotationexception' => '/Framework/MissingCoversAnnotationException.php',
- 'phpunit_framework_outputerror' => '/Framework/OutputError.php',
- 'phpunit_framework_riskytest' => '/Framework/RiskyTest.php',
- 'phpunit_framework_riskytesterror' => '/Framework/RiskyTestError.php',
- 'phpunit_framework_selfdescribing' => '/Framework/SelfDescribing.php',
- 'phpunit_framework_skippedtest' => '/Framework/SkippedTest.php',
- 'phpunit_framework_skippedtestcase' => '/Framework/SkippedTestCase.php',
- 'phpunit_framework_skippedtesterror' => '/Framework/SkippedTestError.php',
- 'phpunit_framework_skippedtestsuiteerror' => '/Framework/SkippedTestSuiteError.php',
- 'phpunit_framework_syntheticerror' => '/Framework/SyntheticError.php',
- 'phpunit_framework_test' => '/Framework/Test.php',
- 'phpunit_framework_testcase' => '/Framework/TestCase.php',
- 'phpunit_framework_testfailure' => '/Framework/TestFailure.php',
- 'phpunit_framework_testlistener' => '/Framework/TestListener.php',
- 'phpunit_framework_testresult' => '/Framework/TestResult.php',
- 'phpunit_framework_testsuite' => '/Framework/TestSuite.php',
- 'phpunit_framework_testsuite_dataprovider' => '/Framework/TestSuite/DataProvider.php',
- 'phpunit_framework_unintentionallycoveredcodeerror' => '/Framework/UnintentionallyCoveredCodeError.php',
- 'phpunit_framework_warning' => '/Framework/Warning.php',
- 'phpunit_framework_warningtestcase' => '/Framework/WarningTestCase.php',
- 'phpunit_runner_basetestrunner' => '/Runner/BaseTestRunner.php',
- 'phpunit_runner_exception' => '/Runner/Exception.php',
- 'phpunit_runner_filter_factory' => '/Runner/Filter/Factory.php',
- 'phpunit_runner_filter_group_exclude' => '/Runner/Filter/Group/Exclude.php',
- 'phpunit_runner_filter_group_include' => '/Runner/Filter/Group/Include.php',
- 'phpunit_runner_filter_groupfilteriterator' => '/Runner/Filter/Group.php',
- 'phpunit_runner_filter_test' => '/Runner/Filter/Test.php',
- 'phpunit_runner_standardtestsuiteloader' => '/Runner/StandardTestSuiteLoader.php',
- 'phpunit_runner_testsuiteloader' => '/Runner/TestSuiteLoader.php',
- 'phpunit_runner_version' => '/Runner/Version.php',
- 'phpunit_textui_command' => '/TextUI/Command.php',
- 'phpunit_textui_resultprinter' => '/TextUI/ResultPrinter.php',
- 'phpunit_textui_testrunner' => '/TextUI/TestRunner.php',
- 'phpunit_util_blacklist' => '/Util/Blacklist.php',
- 'phpunit_util_configuration' => '/Util/Configuration.php',
- 'phpunit_util_configurationgenerator' => '/Util/ConfigurationGenerator.php',
- 'phpunit_util_errorhandler' => '/Util/ErrorHandler.php',
- 'phpunit_util_fileloader' => '/Util/Fileloader.php',
- 'phpunit_util_filesystem' => '/Util/Filesystem.php',
- 'phpunit_util_filter' => '/Util/Filter.php',
- 'phpunit_util_getopt' => '/Util/Getopt.php',
- 'phpunit_util_globalstate' => '/Util/GlobalState.php',
- 'phpunit_util_invalidargumenthelper' => '/Util/InvalidArgumentHelper.php',
- 'phpunit_util_log_json' => '/Util/Log/JSON.php',
- 'phpunit_util_log_junit' => '/Util/Log/JUnit.php',
- 'phpunit_util_log_tap' => '/Util/Log/TAP.php',
- 'phpunit_util_log_teamcity' => '/Util/Log/TeamCity.php',
- 'phpunit_util_php' => '/Util/PHP.php',
- 'phpunit_util_php_default' => '/Util/PHP/Default.php',
- 'phpunit_util_php_windows' => '/Util/PHP/Windows.php',
- 'phpunit_util_printer' => '/Util/Printer.php',
- 'phpunit_util_regex' => '/Util/Regex.php',
- 'phpunit_util_string' => '/Util/String.php',
- 'phpunit_util_test' => '/Util/Test.php',
- 'phpunit_util_testdox_nameprettifier' => '/Util/TestDox/NamePrettifier.php',
- 'phpunit_util_testdox_resultprinter' => '/Util/TestDox/ResultPrinter.php',
- 'phpunit_util_testdox_resultprinter_html' => '/Util/TestDox/ResultPrinter/HTML.php',
- 'phpunit_util_testdox_resultprinter_text' => '/Util/TestDox/ResultPrinter/Text.php',
- 'phpunit_util_testdox_resultprinter_xml' => '/Util/TestDox/ResultPrinter/XML.php',
- 'phpunit_util_testsuiteiterator' => '/Util/TestSuiteIterator.php',
- 'phpunit_util_type' => '/Util/Type.php',
- 'phpunit_util_xml' => '/Util/XML.php',
-),
- "${include_dir}/PHPUnit"
-);
-
-// Dependencies
-\Fedora\Autoloader\Dependencies::required(array(
- "${include_dir}/File/Iterator/autoload.php",
- "${include_dir}/PHP/CodeCoverage/autoload.php",
- "${include_dir}/PHP/Timer/autoload.php",
- "${include_dir}/SebastianBergmann/Version/autoload.php",
- "${include_dir}/SebastianBergmann/Diff/autoload.php",
- "${include_dir}/SebastianBergmann/Environment/autoload.php",
- "${include_dir}/SebastianBergmann/Exporter/autoload.php",
- "${include_dir}/SebastianBergmann/GlobalState/autoload.php",
- "${include_dir}/SebastianBergmann/Comparator/autoload.php",
- "${include_dir}/SebastianBergmann/ObjectEnumerator/autoload.php",
- "${include_dir}/SebastianBergmann/ResourceOperations/autoload.php",
- "${include_dir}/Symfony/Component/Yaml/autoload.php",
- "${include_dir}/Text/Template/autoload.php",
- "${include_dir}/myclabs/DeepCopy/autoload.php",
- "${include_dir}/PHPUnit/Framework/MockObject/autoload.php",
- "${include_dir}/phpspec/Prophecy/autoload.php",
-));
diff --git a/dev-php/phpunit/phpunit-5.7.15-r3.ebuild b/dev-php/phpunit/phpunit-5.7.15-r3.ebuild
deleted file mode 100644
index 601e1c9086e4..000000000000
--- a/dev-php/phpunit/phpunit-5.7.15-r3.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="A PHP Unit Testing framework"
-HOMEPAGE="https://phpunit.de"
-SRC_URI="https://github.com/sebastianbergmann/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ppc ppc64 ~s390 sparc x86"
-IUSE=""
-
-RDEPEND="dev-php/fedora-autoloader
- >=dev-php/File_Iterator-1.4.0
- <dev-php/File_Iterator-2.0
- >=dev-php/Text_Template-1.2.0
- <dev-php/Text_Template-2.0
- >=dev-php/PHP_CodeCoverage-4.0.4
- <dev-php/PHP_CodeCoverage-5.0
- >=dev-php/PHP_Timer-1.0.6
- <dev-php/PHP_Timer-2.0
- <dev-php/myclabs-deepcopy-2.0
- <dev-php/phpspec-prophecy-2.0
- <dev-php/phpunit-mock-objects-4.0
- <dev-php/sebastian-comparator-2.0
- <dev-php/sebastian-diff-2.0
- <dev-php/sebastian-environment-3.0
- <dev-php/sebastian-exporter-3.0
- <dev-php/sebastian-global-state-2.0
- <dev-php/sebastian-object-enumerator-3.0
- <dev-php/sebastian-resource-operations-2.0
- <dev-php/sebastian-version-3.0
- <dev-php/symfony-yaml-4.0
- || (
- dev-lang/php:7.2[cli(-),json(-),unicode(-),xml(-)]
- )"
-
-src_install() {
- insinto /usr/share/php/PHPUnit
- doins -r src/*
- insinto /usr/share/php/PHPUnit/vendor
- doins "${FILESDIR}/autoload.php"
- exeinto /usr/share/php/PHPUnit
- doexe phpunit
- dosym ../share/php/PHPUnit/phpunit /usr/bin/phpunit
-}
-
-pkg_postinst() {
- elog "${PN} can optionally use json, pdo-sqlite and pdo-mysql features."
- elog "If you want those, emerge dev-lang/php with USE=\"json pdo sqlite mysql\"."
-}