summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-06-18 12:17:32 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-06-18 12:27:32 +0200
commit7d01849ddef124578ac7e7fed3411dfd84e1cef3 (patch)
tree43c9fe6950598c3ad17a6a0587c7d2096d544a49 /dev-php
parentsys-libs/libxcrypt: bump up to 4.4.22 (diff)
downloadgentoo-7d01849ddef124578ac7e7fed3411dfd84e1cef3.tar.gz
gentoo-7d01849ddef124578ac7e7fed3411dfd84e1cef3.tar.bz2
gentoo-7d01849ddef124578ac7e7fed3411dfd84e1cef3.zip
dev-php/pecl-imagick: bump to v3.5.0
Closes: https://bugs.gentoo.org/772332 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-imagick/Manifest1
-rw-r--r--dev-php/pecl-imagick/pecl-imagick-3.5.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-php/pecl-imagick/Manifest b/dev-php/pecl-imagick/Manifest
index 1f064c2a8feb..728a5b233324 100644
--- a/dev-php/pecl-imagick/Manifest
+++ b/dev-php/pecl-imagick/Manifest
@@ -1 +1,2 @@
DIST imagick-3.4.4.tgz 253434 BLAKE2B 73ce21547881b60733dbc19ae83cd2e60135dbb4052ea723f1ee10b3759ce12065a0cab2a7e4923b78e9e68b12fd7b875c7d1bd7b2a14ce4e4d7ff5b9c7fbc06 SHA512 73145a1f095849c32760db2dfc4acc13c57d99a037d65eca9b0ddf8f8e81cf6d28a50f2614e44bae1d90b4f881a2e9a64926e0e3b9403e491fd903ffeb30c4b7
+DIST imagick-3.5.0.tgz 300657 BLAKE2B 7cf2c34b84a10f451851493b27a33f7188da0ad53673589db494a6b1a9ae089c5b3e646de4f7b76c29ffb8cbe1c8154ebc8b69d61bc597b082d33778e8f3a18f SHA512 4176494797c78fee28fbf076ee67afe4a634703dd19fa2f727aeb6accc2d65a3fc6224c3131f25d3ac60b2e8d531da2cf76d35800d1f10071cf362067cf531ec
diff --git a/dev-php/pecl-imagick/pecl-imagick-3.5.0.ebuild b/dev-php/pecl-imagick/pecl-imagick-3.5.0.ebuild
new file mode 100644
index 000000000000..48f10a2629b0
--- /dev/null
+++ b/dev-php/pecl-imagick/pecl-imagick-3.5.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PHP_EXT_NAME="imagick"
+USE_PHP="php5-6 php7-1 php7-2 php7-3 php7-4 php8-0"
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+DESCRIPTION="PHP wrapper for the ImageMagick library"
+HOMEPAGE="https://pecl.php.net/imagick https://github.com/mkoppanen/imagick"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+# imagemagick[-openmp] is needed wrt bug 547922 and upstream
+# https://github.com/mkoppanen/imagick#openmp
+RDEPEND=">=media-gfx/imagemagick-6.2.4:=[-openmp]"
+DEPEND="${RDEPEND}
+ test? ( >=media-gfx/imagemagick-6.2.4:=[jpeg,png,svg,truetype,xml] )"
+
+PHP_EXT_ECONF_ARGS="--with-imagick=${EPREFIX}/usr"