summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-01-09 14:15:53 -0500
committerMichael Orlitzky <mjo@gentoo.org>2017-01-09 14:46:01 -0500
commit96a7850b106fa760fc07f99a5227c7c6e6272ebe (patch)
tree18f5dd48d807abd5d4f795dc236f839dc08fce53 /dev-php
parentdev-util/meson: add live ebuild (diff)
downloadgentoo-96a7850b106fa760fc07f99a5227c7c6e6272ebe.tar.gz
gentoo-96a7850b106fa760fc07f99a5227c7c6e6272ebe.tar.bz2
gentoo-96a7850b106fa760fc07f99a5227c7c6e6272ebe.zip
dev-php/PEAR-Services_W3C_CSSValidator: new version 0.2.3.
This new version is the latest one from upstream, dating back to 2012(!). Somehow, this package still works well. In the new version, I've dropped the php-pear-r1 eclass, which greatly overcomplicated things. This package doesn't depend directly on PEAR, so some useless eclass RDEPENDs were dropped, and now the examples are installed in the correct location too. Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-Services_W3C_CSSValidator/Manifest2
-rw-r--r--dev-php/PEAR-Services_W3C_CSSValidator/PEAR-Services_W3C_CSSValidator-0.2.2-r1.ebuild16
-rw-r--r--dev-php/PEAR-Services_W3C_CSSValidator/PEAR-Services_W3C_CSSValidator-0.2.3.ebuild28
-rw-r--r--dev-php/PEAR-Services_W3C_CSSValidator/metadata.xml11
4 files changed, 36 insertions, 21 deletions
diff --git a/dev-php/PEAR-Services_W3C_CSSValidator/Manifest b/dev-php/PEAR-Services_W3C_CSSValidator/Manifest
index eacf5789fdd5..706d14ef5855 100644
--- a/dev-php/PEAR-Services_W3C_CSSValidator/Manifest
+++ b/dev-php/PEAR-Services_W3C_CSSValidator/Manifest
@@ -1 +1 @@
-DIST Services_W3C_CSSValidator-0.2.2.tgz 10260 SHA256 698d60f2bb4c1e1ca2b95226a87575c8ceeb4912dcd5e87ebe3fd320afea4c5f SHA512 a2d5c8bbf6d18ee14804661ba537b4be0328127196085e14c7b74760811f637827c8a07b81a844e14dfcae6ed2fedcc3bfd502b958aad4253b742c4d7f39a60f WHIRLPOOL f057d38cf2a2da87e47a145e92ae14e42892186f98e08ae2e129d91b5fcf66b5ff12a3103fdd25ec5d431668ba90cf045fe53284df5b69771a3ea378927a5338
+DIST Services_W3C_CSSValidator-0.2.3.tgz 10721 SHA256 2f8c3d4209eaffa20c3d05e0d9fb3caf087e87a7199e217b5b01dacacc6fd218 SHA512 4f9fb73ec57e374018b389f50918eaf87a63885f75b0ae2ead067e949a451ddbe40da8020672834e891106b5d470fbe451b3117233678b5f6f6a85f01d2a8aef WHIRLPOOL ed04cfd34a08560a8cdf5040d89f4dc0b1e163da44cb75e2409e864d5b50d0300d78caaede98872a28265775ac44f5e29d9769060dcc75be93c54eb555a67e34
diff --git a/dev-php/PEAR-Services_W3C_CSSValidator/PEAR-Services_W3C_CSSValidator-0.2.2-r1.ebuild b/dev-php/PEAR-Services_W3C_CSSValidator/PEAR-Services_W3C_CSSValidator-0.2.2-r1.ebuild
deleted file mode 100644
index 0aaa90aefada..000000000000
--- a/dev-php/PEAR-Services_W3C_CSSValidator/PEAR-Services_W3C_CSSValidator-0.2.2-r1.ebuild
+++ /dev/null
@@ -1,16 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-inherit php-pear-r1
-
-DESCRIPTION="Provides an object oriented interface for the W3 CSS Validator"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-php/PEAR-HTTP_Request2-0.2.0"
diff --git a/dev-php/PEAR-Services_W3C_CSSValidator/PEAR-Services_W3C_CSSValidator-0.2.3.ebuild b/dev-php/PEAR-Services_W3C_CSSValidator/PEAR-Services_W3C_CSSValidator-0.2.3.ebuild
new file mode 100644
index 000000000000..bd51e9c1d512
--- /dev/null
+++ b/dev-php/PEAR-Services_W3C_CSSValidator/PEAR-Services_W3C_CSSValidator-0.2.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Provides an object oriented interface for the W3 CSS Validator"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="dev-lang/php:*
+ dev-php/PEAR-HTTP_Request2"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ use examples && dodoc -r docs/examples
+
+ insinto /usr/share/php
+ doins -r Services
+}
diff --git a/dev-php/PEAR-Services_W3C_CSSValidator/metadata.xml b/dev-php/PEAR-Services_W3C_CSSValidator/metadata.xml
index b86acf66c756..2bffd835b197 100644
--- a/dev-php/PEAR-Services_W3C_CSSValidator/metadata.xml
+++ b/dev-php/PEAR-Services_W3C_CSSValidator/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>php-bugs@gentoo.org</email>
- <name>PHP</name>
- </maintainer>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pear/Services_W3C_CSSValidator</remote-id>
+ </upstream>
</pkgmetadata>