summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-03-02 20:50:24 +0100
committerSam James <sam@gentoo.org>2021-03-03 16:51:46 +0000
commit9cbc504a56cd84ccc840a394f5ac419b5d7d68c1 (patch)
tree182894d15f10f6e3c3a2487cb114b1f79ec688d0 /dev-php
parentsys-apps/linux-misc-apps: Remove old (diff)
downloadgentoo-9cbc504a56cd84ccc840a394f5ac419b5d7d68c1.tar.gz
gentoo-9cbc504a56cd84ccc840a394f5ac419b5d7d68c1.tar.bz2
gentoo-9cbc504a56cd84ccc840a394f5ac419b5d7d68c1.zip
dev-php/libvirt-php: Apply gcc-10 workaround
Closes: https://bugs.gentoo.org/728326 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/libvirt-php/libvirt-php-0.5.5.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-php/libvirt-php/libvirt-php-0.5.5.ebuild b/dev-php/libvirt-php/libvirt-php-0.5.5.ebuild
index dae081f9be6e..df9088443f65 100644
--- a/dev-php/libvirt-php/libvirt-php-0.5.5.ebuild
+++ b/dev-php/libvirt-php/libvirt-php-0.5.5.ebuild
@@ -8,7 +8,7 @@ PHP_EXT_SKIP_PHPIZE="yes"
USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3"
PHP_EXT_ECONF_ARGS=()
-inherit php-ext-source-r3 autotools
+inherit php-ext-source-r3 autotools flag-o-matic
DESCRIPTION="PHP bindings for libvirt"
HOMEPAGE="http://libvirt.org/php/"
@@ -50,6 +50,11 @@ src_prepare() {
done
}
+src_configure() {
+ append-cflags -fcommon
+ php-ext-source-r3_src_configure
+}
+
src_install() {
local slot
for slot in $(php_get_slots); do