summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaco Kroon <jaco@uls.co.za>2022-10-24 09:25:53 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-10-26 21:47:40 +0200
commita4b53e1afca25080abec7c37344e052d5ce86c6e (patch)
tree9f6233d926e1cf79907f44b78d71c68bf7a8af4c /dev-php
parentwww-servers/nginx: remove unused patch (diff)
downloadgentoo-a4b53e1afca25080abec7c37344e052d5ce86c6e.tar.gz
gentoo-a4b53e1afca25080abec7c37344e052d5ce86c6e.tar.bz2
gentoo-a4b53e1afca25080abec7c37344e052d5ce86c6e.zip
dev-php/pecl-parallel: bump 1.1.4
Move to EAPI=8. Fix test failures (php7.3 support removed, as far as I can tell these failing tests were due to issues in the way php7.3 handled the testing). Closes: https://bugs.gentoo.org/815124 Signed-off-by: Jaco Kroon <jaco@uls.co.za> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-parallel/pecl-parallel-1.1.4-r1.ebuild (renamed from dev-php/pecl-parallel/pecl-parallel-1.1.4.ebuild)17
1 files changed, 5 insertions, 12 deletions
diff --git a/dev-php/pecl-parallel/pecl-parallel-1.1.4.ebuild b/dev-php/pecl-parallel/pecl-parallel-1.1.4-r1.ebuild
index 5d0e7fc04b47..64ba94830ab9 100644
--- a/dev-php/pecl-parallel/pecl-parallel-1.1.4.ebuild
+++ b/dev-php/pecl-parallel/pecl-parallel-1.1.4-r1.ebuild
@@ -1,13 +1,15 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI="8"
PHP_EXT_NAME="parallel"
PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
+PHP_EXT_NEEDED_USE="threads"
-USE_PHP="php7-3 php7-4"
+USE_PHP="php7-4"
+SLOT="7"
inherit php-ext-pecl-r3
@@ -17,12 +19,3 @@ KEYWORDS="~amd64 ~x86"
DESCRIPTION="A succint parallel concurrency API for PHP"
LICENSE="PHP-3.01"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- php_targets_php7-3? ( dev-lang/php:7.3[threads] )
- php_targets_php7-4? ( dev-lang/php:7.4[threads] )
-"
-DEPEND="test? ( ${RDEPEND} )"