summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-09-15 09:52:21 +0200
committerDavid Seifert <soap@gentoo.org>2023-09-15 09:52:21 +0200
commita7d8000791f23a91213f093a974d883b8fe3951b (patch)
tree107a5f5bbef149a89c2c544715e2f97289ab4d5f /dev-php
parentdev-php/phpunit: treeclean (diff)
downloadgentoo-a7d8000791f23a91213f093a974d883b8fe3951b.tar.gz
gentoo-a7d8000791f23a91213f093a974d883b8fe3951b.tar.bz2
gentoo-a7d8000791f23a91213f093a974d883b8fe3951b.zip
dev-php/phpspec-prophecy: treeclean
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/phpspec-prophecy/Manifest1
-rw-r--r--dev-php/phpspec-prophecy/files/autoload-1.10.0.php15
-rw-r--r--dev-php/phpspec-prophecy/files/autoload.php15
-rw-r--r--dev-php/phpspec-prophecy/metadata.xml12
-rw-r--r--dev-php/phpspec-prophecy/phpspec-prophecy-1.14.0.ebuild31
5 files changed, 0 insertions, 74 deletions
diff --git a/dev-php/phpspec-prophecy/Manifest b/dev-php/phpspec-prophecy/Manifest
deleted file mode 100644
index 45d0f97748e2..000000000000
--- a/dev-php/phpspec-prophecy/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST phpspec-prophecy-1.14.0.tar.gz 40801 BLAKE2B 8968be07cbc02f76c515c8c6a27e69662e1aa697e5d502329a946a677903b59fc63347b2535b84ebf4e1d59cf6085fa10151ed9caea9f3b50c1897eaeb178636 SHA512 777137784a2235ae638d1b6b42bb67b2fa6eadb2c05e83097e90604aee5e0d7bc4100924fadf8f2e5ccbe09be6d4edf4fb63606f2be4a9c805dc4480d88747ef
diff --git a/dev-php/phpspec-prophecy/files/autoload-1.10.0.php b/dev-php/phpspec-prophecy/files/autoload-1.10.0.php
deleted file mode 100644
index fbc88617da61..000000000000
--- a/dev-php/phpspec-prophecy/files/autoload-1.10.0.php
+++ /dev/null
@@ -1,15 +0,0 @@
-<?php
-/* Autoloader for dev-php/phpspec-prophecy */
-
-if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
- require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
-}
-
-Fedora\Autoloader\Autoload::addPsr4('Prophecy\\', __DIR__);
-
-\Fedora\Autoloader\Dependencies::required(array(
- '/usr/share/php/phpDocumentor/ReflectionDocBlock/autoload.php',
- '/usr/share/php/SebastianBergmann/Comparator/autoload.php',
- '/usr/share/php/Doctrine/Instantiator/autoload.php',
- '/usr/share/php/SebastianBergmann/RecursionContext/autoload.php',
-));
diff --git a/dev-php/phpspec-prophecy/files/autoload.php b/dev-php/phpspec-prophecy/files/autoload.php
deleted file mode 100644
index eb61ccb5eedb..000000000000
--- a/dev-php/phpspec-prophecy/files/autoload.php
+++ /dev/null
@@ -1,15 +0,0 @@
-<?php
-/* Autoloader for dev-php/phpspec-prophecy */
-
-if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
- require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
-}
-
-Fedora\Autoloader\Autoload::addPsr0('Prophecy\\', __DIR__);
-
-\Fedora\Autoloader\Dependencies::required(array(
- '/usr/share/php/phpDocumentor/ReflectionDocBlock/autoload.php',
- '/usr/share/php/SebastianBergmann/Comparator/autoload.php',
- '/usr/share/php/Doctrine/Instantiator/autoload.php',
- '/usr/share/php/SebastianBergmann/RecursionContext/autoload.php',
-));
diff --git a/dev-php/phpspec-prophecy/metadata.xml b/dev-php/phpspec-prophecy/metadata.xml
deleted file mode 100644
index 9ff0adfe1748..000000000000
--- a/dev-php/phpspec-prophecy/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>php-bugs@gentoo.org</email>
- <name>PHP</name>
- </maintainer>
- <stabilize-allarches/>
- <upstream>
- <remote-id type="github">phpspec/prophecy</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-php/phpspec-prophecy/phpspec-prophecy-1.14.0.ebuild b/dev-php/phpspec-prophecy/phpspec-prophecy-1.14.0.ebuild
deleted file mode 100644
index 6f43e7757c29..000000000000
--- a/dev-php/phpspec-prophecy/phpspec-prophecy-1.14.0.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-MY_PN="prophecy"
-MY_VENDOR="phpspec"
-
-DESCRIPTION="Highly opinionated mocking framework"
-HOMEPAGE="https://github.com/phpspec/prophecy"
-SRC_URI="https://github.com/${MY_VENDOR}/${MY_PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ppc ppc64 ~s390 sparc x86"
-IUSE=""
-
-S="${WORKDIR}/prophecy-${PV}"
-
-RDEPEND="dev-php/fedora-autoloader
- <dev-php/doctrine-instantiator-2
- <dev-php/phpdocumentor-reflection-docblock-6
- <dev-php/sebastian-comparator-4
- <dev-php/sebastian-recursion-context-4
- >=dev-lang/php-5.6:*"
-
-src_install() {
- insinto /usr/share/php/${MY_VENDOR}/Prophecy
- doins -r src/Prophecy/*
- newins "${FILESDIR}/autoload-1.10.0.php" autoload.php
-}