summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-01-09 23:56:47 -0500
committerMichael Orlitzky <mjo@gentoo.org>2017-01-09 23:56:47 -0500
commita8c33b06974bc0be21c0efd593c2ed80facaafd0 (patch)
treea0c4e5269b90f2310163e5e702db6ba4bf064a3d /dev-php
parentdev-php/PEAR-PHP_Beautifier: new revision sans the php-pear-r1 eclass. (diff)
downloadgentoo-a8c33b06974bc0be21c0efd593c2ed80facaafd0.tar.gz
gentoo-a8c33b06974bc0be21c0efd593c2ed80facaafd0.tar.bz2
gentoo-a8c33b06974bc0be21c0efd593c2ed80facaafd0.zip
dev-php/PEAR-Net_DNSBL: new EAPI=6 revision.
This new revision drops the php-pear-r1 eclass, which means that the examples are now installed in the correct place. They're also hidden behind USE=examples, as are the associated dependencies. The other major reason for the new revision is to drop the erroneous RDEPEND on dev-php/PEAR-Net_CheckIP. That package is not needed, and should be last-rited once this new revision has stabilized. Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-Net_DNSBL/PEAR-Net_DNSBL-1.3.7-r1.ebuild31
-rw-r--r--dev-php/PEAR-Net_DNSBL/metadata.xml11
2 files changed, 38 insertions, 4 deletions
diff --git a/dev-php/PEAR-Net_DNSBL/PEAR-Net_DNSBL-1.3.7-r1.ebuild b/dev-php/PEAR-Net_DNSBL/PEAR-Net_DNSBL-1.3.7-r1.ebuild
new file mode 100644
index 000000000000..cd4446fd2f05
--- /dev/null
+++ b/dev-php/PEAR-Net_DNSBL/PEAR-Net_DNSBL-1.3.7-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="PHP library to query DNS blacklists"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~sparc ~x86"
+IUSE="examples"
+RDEPEND="dev-lang/php:*
+ dev-php/PEAR-Cache_Lite
+ dev-php/PEAR-HTTP_Request2
+ dev-php/PEAR-Net_DNS
+ dev-php/PEAR-PEAR
+ examples? ( dev-lang/php:*[cli] dev-php/PEAR-Console_Getopt )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ use examples && dodoc -r examples
+
+ insinto /usr/share/php
+ doins -r Net
+}
diff --git a/dev-php/PEAR-Net_DNSBL/metadata.xml b/dev-php/PEAR-Net_DNSBL/metadata.xml
index aca42932b833..770ab1c7fcac 100644
--- a/dev-php/PEAR-Net_DNSBL/metadata.xml
+++ b/dev-php/PEAR-Net_DNSBL/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>php-bugs@gentoo.org</email>
- <name>PHP</name>
-</maintainer>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pear/Net_DNSBL</remote-id>
+ </upstream>
</pkgmetadata>