summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-03-19 22:50:03 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-03-19 22:54:52 +0100
commitac498ba0da0e954c67da4baccc6f0fea68faf7a9 (patch)
treec4e4e7dd9b812bd63b70b1fb5d121465828ae608 /dev-php
parentdev-php/symfony-console: bump to v2.8.52 (diff)
downloadgentoo-ac498ba0da0e954c67da4baccc6f0fea68faf7a9.tar.gz
gentoo-ac498ba0da0e954c67da4baccc6f0fea68faf7a9.tar.bz2
gentoo-ac498ba0da0e954c67da4baccc6f0fea68faf7a9.zip
dev-php/symfony-filesystem: bump to v3.4.36
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/symfony-filesystem/Manifest1
-rw-r--r--dev-php/symfony-filesystem/symfony-filesystem-3.4.36.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-php/symfony-filesystem/Manifest b/dev-php/symfony-filesystem/Manifest
index 5442b6d1d3ff..549662a3198d 100644
--- a/dev-php/symfony-filesystem/Manifest
+++ b/dev-php/symfony-filesystem/Manifest
@@ -1 +1,2 @@
DIST symfony-filesystem-3.4.28.tar.gz 19238 BLAKE2B dcb9752a5691834aa87b3866b6c2f53b54d5953cf721547cf3ae8aa03e826bcacb2393f324bf9a767013a2daebcf9654c7ce18822ac40758d96b35b174b8ab6d SHA512 4a2e19bf6df69396e503e11112d9b37e9deaaba5eb4fa95857b7b19e1ce073462d2ca18442b6cc1c30021f925d0878f635aa9bc1c5de55318f0c521a291efcc8
+DIST symfony-filesystem-3.4.36.tar.gz 19282 BLAKE2B fd084715356b49588ff6a589372ab1958e3bd58b3af690b554ef1562553bf57504ca184fea06a3aa58ea12381773cebb57e11ba385be5c23ebce3f9e576413ec SHA512 2a43d22e64adfe50a1915f3833c70962f90a8da3cf7bb8b7bf30b1e0f17d6bd4857b35687207e019037d24ad71f46228ddd6eb46713117b82a92f94653cb2384
diff --git a/dev-php/symfony-filesystem/symfony-filesystem-3.4.36.ebuild b/dev-php/symfony-filesystem/symfony-filesystem-3.4.36.ebuild
new file mode 100644
index 000000000000..03a6ae68819b
--- /dev/null
+++ b/dev-php/symfony-filesystem/symfony-filesystem-3.4.36.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Symfony Filesystem Component"
+HOMEPAGE="https://github.com/symfony/filesystem"
+SRC_URI="https://github.com/symfony/filesystem/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-lang/php:*
+ dev-php/fedora-autoloader"
+DEPEND="test? ( ${RDEPEND} >=dev-php/phpunit-5.7.15 )"
+
+S="${WORKDIR}/filesystem-${PV}"
+
+src_prepare() {
+ default
+ if use test; then
+ cp "${FILESDIR}/autoload.php" "${S}/autoload-test.php" || die
+ fi
+}
+
+src_install() {
+ insinto "/usr/share/php/Symfony/Component/Filesystem"
+ doins -r Exception
+ doins *.php "${FILESDIR}/autoload.php"
+ dodoc CHANGELOG.md README.md
+}
+
+src_test() {
+ phpunit --bootstrap "${S}/autoload-test.php" \
+ --exclude-group network || die 'test suite failed'
+}