summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2020-04-21 07:45:59 +0000
committerThomas Deutschmann <whissi@gentoo.org>2020-04-21 13:06:51 +0200
commitae3b17c8be02a6c7a8764ad2890f50218eb55294 (patch)
tree2d3c95dba0bb0325399ea4b2cce71a38dfa3e4e9 /dev-php
parentnet-misc/dhcpcd: Removed old (diff)
downloadgentoo-ae3b17c8be02a6c7a8764ad2890f50218eb55294.tar.gz
gentoo-ae3b17c8be02a6c7a8764ad2890f50218eb55294.tar.bz2
gentoo-ae3b17c8be02a6c7a8764ad2890f50218eb55294.zip
dev-php/composer: bump to 1.10.5
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/15449 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/composer/Manifest1
-rw-r--r--dev-php/composer/composer-1.10.5.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-php/composer/Manifest b/dev-php/composer/Manifest
index 74ca55b3c003..8fea8db5fa96 100644
--- a/dev-php/composer/Manifest
+++ b/dev-php/composer/Manifest
@@ -1,2 +1,3 @@
DIST composer-1.10.1.tar.gz 421852 BLAKE2B a40f59ab0af5eba777f1926bab78e55fd1973e53b324eec73fdca70678fc1cfe6f892790a61a66dbdbe07caa03343bfd109318daec99c2c18707785c6bf149e0 SHA512 ebc3ee48bf0d2597e7221e9ac0ab7188e7a99096d5dacdee4176b4c7b4d252d079c117b5bd9131ff38d8963f95930fa9c83fa51ed542d4f7d58276561de1f2b8
+DIST composer-1.10.5.tar.gz 423065 BLAKE2B 0c8595f3583a692f89294455984aeff2ad9cbf2a39541355cbb736e717baacae8245fa81e6b9fde11dd5bb56ad3a074262f6f8ecb65b4bef9c782ef39887deec SHA512 cdadb2d146afcc140316b83d3b4f4c018d79e8222f6a6207cdd52db75ae9c78e787a509d88a3fe113f8218df2ace56ba2dd043e1b6e6c3dbb5129fd51d8e9925
DIST composer-1.9.3.tar.gz 412212 BLAKE2B fc293a38baaf87cc2581304e1438d48e94a85ca2c5da4eff388b1307dadacb67327d9612211af70f1734872c7a377b8713492839c2d330c9e0e7226206cdc1f6 SHA512 42a37b2187895e06f2dc8c5225a1328377afc408ad28af12d9ef5d15fe083dcf22459ce0f482abfd528683113af5f9fd1a19758294c59c69b59a5bb32e65f2cc
diff --git a/dev-php/composer/composer-1.10.5.ebuild b/dev-php/composer/composer-1.10.5.ebuild
new file mode 100644
index 000000000000..29915836e3cf
--- /dev/null
+++ b/dev-php/composer/composer-1.10.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Dependency Manager for PHP"
+HOMEPAGE="https://github.com/composer/composer"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-lang/php:*[curl]
+ >=dev-php/ca-bundle-1.1.3
+ >=dev-php/psr-log-1.1.0
+ dev-php/fedora-autoloader
+ >=dev-php/json-schema-5.2.7
+ >=dev-php/jsonlint-1.7.1
+ >=dev-php/phar-utils-1.0.1
+ >=dev-php/semver-1.4.2
+ >=dev-php/spdx-licenses-1.5.0
+ >=dev-php/symfony-console-2.8.48
+ >=dev-php/symfony-filesystem-2.8.48
+ >=dev-php/symfony-finder-2.8.49
+ >=dev-php/symfony-process-2.8.48
+ >=dev-php/xdebug-handler-1.3.1"
+
+src_install() {
+ insinto "/usr/share/${PN}"
+
+ # Composer expects the LICENSE file to be there, and the
+ # easiest thing to do is to give it what it wants.
+ doins -r src res LICENSE
+
+ insinto "/usr/share/${PN}/vendor"
+ newins "${FILESDIR}"/autoload-r1.php autoload.php
+
+ exeinto "/usr/share/${PN}/bin"
+ doexe "bin/${PN}"
+ dosym "../share/${PN}/bin/${PN}" "/usr/bin/${PN}"
+
+ dodoc CHANGELOG.md README.md doc/*.md
+ dodoc -r doc/articles doc/faqs
+}