summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2022-03-17 10:15:41 -0400
committerBrian Evans <grknight@gentoo.org>2022-03-17 10:15:41 -0400
commitc3266dbae458c687a9957755dafa208537d7acc7 (patch)
tree79d97b0e64dce1021ec7210297bf2a11a49eca50 /dev-php
parentdev-php/swoole-async: Update targets (diff)
downloadgentoo-c3266dbae458c687a9957755dafa208537d7acc7.tar.gz
gentoo-c3266dbae458c687a9957755dafa208537d7acc7.tar.bz2
gentoo-c3266dbae458c687a9957755dafa208537d7acc7.zip
dev-php/swoole: Drop old; update target
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/swoole/Manifest1
-rw-r--r--dev-php/swoole/swoole-4.4.12.ebuild73
-rw-r--r--dev-php/swoole/swoole-4.4.16.ebuild10
3 files changed, 2 insertions, 82 deletions
diff --git a/dev-php/swoole/Manifest b/dev-php/swoole/Manifest
index 9dcf3ebb7a11..a44e9a230a1e 100644
--- a/dev-php/swoole/Manifest
+++ b/dev-php/swoole/Manifest
@@ -1,4 +1,3 @@
-DIST swoole-4.4.12.tgz 1436554 BLAKE2B cc9e64e108aa9b393265708a6922f53824c2e9941c0f47f4f6aacf93239829381cdf4625af8f30e2ca8ceb1663047c6be8b2d7808dbc29d27100135288f7ac85 SHA512 8899bb048b85c048903c80fe1af045ea4f82a25b3b4fd9995d51c8a2ab144306f9f5651276776e3f6a29c83322fb0aeee2822d131247070fe9e2e87b26f2e0e9
DIST swoole-4.4.16.tgz 1457270 BLAKE2B 4b65270aa1014ea68cadae8eb021d37498dc3fe0bf2d681c95bf7113928138bc26ab73f3be91185eb5ecebcb4940906814913c7908c87592aafd33fbc1820bf7 SHA512 7be4705967ed6b7a955f679f8c39585d34dc8c87ba608ac3ae2b0fc3cae9513d9639c8e9aac4278ce85acc215b500044626aab9b2aac725c9ffaef72dfb02dd7
DIST swoole-4.5.9.tgz 1552445 BLAKE2B 602ce65f7b59a3c199d7718aeb941d1ebde7d59096335992c2278f7e330f7b48554a8418cc4014f6fcf47af92d315368a16c572055b1fd9575608c2559ed3107 SHA512 9154a2874480218aa3c8935979267efb92a3d5a4f1ba7dc071bf4c2b169d69e31a6ad7412785d00543dc5827ce2d6c5999b6cabea2089818f3f57acc26bcb31f
DIST swoole-4.8.7.tgz 1851160 BLAKE2B 3e5c9d664f1897b7bd490a1e9dbc4c3c03117a18ae58586efe534c617578a7af5be779e6ca44a5bf2f782abc2eb57bc21e3dc4e3445c3299918bc189547dc75c SHA512 36f36aface71435233aaa8c81e023b813c6175d3ed00a9de20acb690b58b464d99670c3b96f247ab1147f95e099d44785d60d5f1e36f519ccfeb09b3bddba264
diff --git a/dev-php/swoole/swoole-4.4.12.ebuild b/dev-php/swoole/swoole-4.4.12.ebuild
deleted file mode 100644
index 4d978ebbd611..000000000000
--- a/dev-php/swoole/swoole-4.4.12.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PHP_EXT_NAME="swoole"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-PHP_EXT_SAPIS="cli"
-DOCS=( README.md )
-
-USE_PHP="php7-1 php7-2 php7-3 php7-4"
-
-inherit php-ext-pecl-r3
-
-HOMEPAGE="https://www.swoole.co.uk"
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="Event-driven asynchronous & concurrent & coroutine networking engine"
-LICENSE="Apache-2.0"
-SLOT="0"
-# Tests can hang. Disable until this no longer happens
-RESTRICT="test"
-
-DEPEND="
- app-arch/brotli:0=
- dev-libs/libaio
- dev-libs/boost:0=
- dev-libs/libpcre
- sys-libs/zlib:0=
- http2? ( net-libs/nghttp2:0= )
- ssl? (
- dev-libs/openssl:0=
- )
- php_targets_php7-1? ( dev-lang/php:7.1[cli,sockets?] )
- php_targets_php7-2? ( dev-lang/php:7.2[cli,sockets?] )
- php_targets_php7-3? ( dev-lang/php:7.3[cli,sockets?] )
- php_targets_php7-4? ( dev-lang/php:7.4[cli,sockets?] )
- mysql? (
- php_targets_php7-1? ( dev-lang/php:7.1[mysql,mysqli(+)] )
- php_targets_php7-2? ( dev-lang/php:7.2[mysql,mysqli(+)] )
- php_targets_php7-3? ( dev-lang/php:7.3[mysql,mysqli(+)] )
- php_targets_php7-4? ( dev-lang/php:7.4[mysql,mysqli(+)] )
- )
-"
-
-RDEPEND="${DEPEND}"
-
-IUSE="debug http2 mysql sockets ssl"
-
-src_configure() {
- # JEMalloc not included as it refuses to find a ${ESYSROOT}/usr/includes/jemalloc subdirectory
- local PHP_EXT_ECONF_ARGS=(
- --enable-swoole
- $(use_enable debug)
- $(use_enable http2)
- $(use_enable mysql mysqlnd)
- $(use_enable ssl openssl)
- $(use_with ssl openssl-dir "${ESYSROOT}/usr")
- $(use_enable sockets)
- )
-
- php-ext-source-r3_src_configure
-}
-
-src_test() {
- local slot
- for slot in $(php_get_slots); do
- php_init_slot_env "${slot}"
- [[ -f tests/template.phpt ]] && rm tests/template.phpt
- SKIP_ONLINE_TESTS="yes" NO_INTERACTION="yes" emake test
- done
-}
diff --git a/dev-php/swoole/swoole-4.4.16.ebuild b/dev-php/swoole/swoole-4.4.16.ebuild
index 4d978ebbd611..ae1a5e1862af 100644
--- a/dev-php/swoole/swoole-4.4.16.ebuild
+++ b/dev-php/swoole/swoole-4.4.16.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -9,7 +9,7 @@ PHP_EXT_ZENDEXT="no"
PHP_EXT_SAPIS="cli"
DOCS=( README.md )
-USE_PHP="php7-1 php7-2 php7-3 php7-4"
+USE_PHP="php7-4"
inherit php-ext-pecl-r3
@@ -32,14 +32,8 @@ DEPEND="
ssl? (
dev-libs/openssl:0=
)
- php_targets_php7-1? ( dev-lang/php:7.1[cli,sockets?] )
- php_targets_php7-2? ( dev-lang/php:7.2[cli,sockets?] )
- php_targets_php7-3? ( dev-lang/php:7.3[cli,sockets?] )
php_targets_php7-4? ( dev-lang/php:7.4[cli,sockets?] )
mysql? (
- php_targets_php7-1? ( dev-lang/php:7.1[mysql,mysqli(+)] )
- php_targets_php7-2? ( dev-lang/php:7.2[mysql,mysqli(+)] )
- php_targets_php7-3? ( dev-lang/php:7.3[mysql,mysqli(+)] )
php_targets_php7-4? ( dev-lang/php:7.4[mysql,mysqli(+)] )
)
"