summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-01-19 19:12:29 -0500
committerMichael Orlitzky <mjo@gentoo.org>2017-01-19 19:12:46 -0500
commitc6e61c1e57365284b061ade8fd66ec9cd4ebfb25 (patch)
treec938c19976c0cca32b5d8b19c5b29ca74a075187 /dev-php
parentsys-apps/shadow: Make gettext DEPEND unconditional (diff)
downloadgentoo-c6e61c1e57365284b061ade8fd66ec9cd4ebfb25.tar.gz
gentoo-c6e61c1e57365284b061ade8fd66ec9cd4ebfb25.tar.bz2
gentoo-c6e61c1e57365284b061ade8fd66ec9cd4ebfb25.zip
dev-php/PEAR-Console_CommandLine: new version 1.2.2.
This new version drops the php-pear-r1 eclass in exchange for a few fixes. The documentation (examples) are now installed in the correct location, behind USE=examples. The xmlschema.rng data file is installed outside of the PHP include directory, since it is not included by PHP code. And finally, the (working) test suite has been enabled. Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-Console_CommandLine/Manifest1
-rw-r--r--dev-php/PEAR-Console_CommandLine/PEAR-Console_CommandLine-1.2.2.ebuild53
-rw-r--r--dev-php/PEAR-Console_CommandLine/metadata.xml14
3 files changed, 61 insertions, 7 deletions
diff --git a/dev-php/PEAR-Console_CommandLine/Manifest b/dev-php/PEAR-Console_CommandLine/Manifest
index c745ccb13781..fe2cd36f34e2 100644
--- a/dev-php/PEAR-Console_CommandLine/Manifest
+++ b/dev-php/PEAR-Console_CommandLine/Manifest
@@ -1,2 +1,3 @@
DIST Console_CommandLine-1.2.0.tgz 39740 SHA256 18f2cbed4ab2af1c5423e5f24bc1689f4d789b1bb36dde2e0c4d198d7c71c17e SHA512 398955e43d95f5c2bf7ec61b17e0b87db6967010a3f3489131588bbcca3fb9d188829c7e54dd06197df21e4ee5e10c5f50b28df20bdf6690d89722c409060c24 WHIRLPOOL 6e3d9c133b3d2a878e1806d49294199ee0015e4efe40169ce041b7ae1571fc58eaef5abb9dfdf03957f16a2664ecf2a08db951716419f234db9e3339767185a2
DIST Console_CommandLine-1.2.1.tgz 40662 SHA256 a436c55d12c90125d2e69becb125d327f38d5fc6a75c93501213b2bc83956837 SHA512 7ba1ef74c9afc75be26c313fcbf3420bcfb5bfa553be54a88a8e13ef455a51e8f8ee749113bfbd59bd0e4b1a27142d743293bebcf2606b120fa18737f30b1d2e WHIRLPOOL 05f011da7cd4384d0bd4bdbda23cd138b243a7acf95ab5b8764adf2d22192638066ec26af436a256cc0fba8e5e44a484c7b023017e62b59874d20249c1a67761
+DIST Console_CommandLine-1.2.2.tgz 40705 SHA256 38d677e321c33bbf179cc9e4ec7840b63fef70531f1ce797fb09b50bcc94a417 SHA512 05dbde123d0d4fdbba2a959f4bea3b115e3629060a268d25a3007c2ee5a3530b8ebbd8c7d124a6c9d012cafa19f41690a888943a6c1e2e5ec1b9d83fa821d603 WHIRLPOOL fd7651e46528506a87b10e7838be6663a82c40e63803993a33bac0ac165c45d0444b1a26a3c269f514db024d14ebfeb6188c4b4c3fc8f24b974244bd357c07e7
diff --git a/dev-php/PEAR-Console_CommandLine/PEAR-Console_CommandLine-1.2.2.ebuild b/dev-php/PEAR-Console_CommandLine/PEAR-Console_CommandLine-1.2.2.ebuild
new file mode 100644
index 000000000000..569e460bd273
--- /dev/null
+++ b/dev-php/PEAR-Console_CommandLine/PEAR-Console_CommandLine-1.2.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A full-featured command-line options and arguments parser"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="examples test"
+
+# Only needs PEAR_Exception (not yet packaged) -- not all of PEAR-PEAR.
+RDEPEND="dev-lang/php:*
+ dev-php/PEAR-PEAR"
+
+# Beware, the test suite really needs PEAR-PEAR.
+DEPEND="test? ( ${RDEPEND} )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # There's one occurrence of @data_dir@ that needs to be replaced
+ # This location just has to agree with where we put the "data"
+ # directory during src_install().
+ default
+ sed -i "s|@data_dir@|${EPREFIX}/usr/share|" \
+ Console/CommandLine/XmlParser.php || die
+}
+
+src_install() {
+ use examples && dodoc -r docs/examples
+
+ insinto "/usr/share/${MY_PN}"
+ doins -r data
+
+ insinto /usr/share/php
+ doins -r Console
+}
+
+src_test() {
+ # Requires the "pear" executable from dev-php/PEAR-PEAR.
+ pear run-tests tests || die
+
+ # The command succeeds regardless of whether or not the test suite
+ # passed, but this file is only written when there was a failure.
+ [[ -f run-tests.log ]] && die "test suite failed"
+}
diff --git a/dev-php/PEAR-Console_CommandLine/metadata.xml b/dev-php/PEAR-Console_CommandLine/metadata.xml
index 1b669c90eb8b..8f44a5b2854b 100644
--- a/dev-php/PEAR-Console_CommandLine/metadata.xml
+++ b/dev-php/PEAR-Console_CommandLine/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
-<email>php-bugs@gentoo.org</email>
-<name>PHP</name>
-</maintainer>
-<longdescription lang="en">
-A full featured command line options and arguments parser
-</longdescription>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pear/Console_CommandLine</remote-id>
+ </upstream>
</pkgmetadata>