summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-05-28 10:56:29 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-05-28 10:58:55 +0200
commitd5ebd6bf4c1d4cdce4f09ae744249840eb6a345a (patch)
treee12f43f9c857221d7c3d1fd2eb03bae3de1d551f /dev-php
parentsys-cluster/singularity: drop 3.7.3 (diff)
downloadgentoo-d5ebd6bf4c1d4cdce4f09ae744249840eb6a345a.tar.gz
gentoo-d5ebd6bf4c1d4cdce4f09ae744249840eb6a345a.tar.bz2
gentoo-d5ebd6bf4c1d4cdce4f09ae744249840eb6a345a.zip
dev-php/xdebug-handler: bump to v2.0.1
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/xdebug-handler/Manifest1
-rw-r--r--dev-php/xdebug-handler/xdebug-handler-2.0.1.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-php/xdebug-handler/Manifest b/dev-php/xdebug-handler/Manifest
index 6f80b3a797ac..7e641018ea3c 100644
--- a/dev-php/xdebug-handler/Manifest
+++ b/dev-php/xdebug-handler/Manifest
@@ -1 +1,2 @@
DIST xdebug-handler-1.4.3.tar.gz 13660 BLAKE2B 2edbd2755102ced0183e6d7ade341ed830b4c1d923f453868d29f39aa7de5159758fd162a369246adf4551a8a06c0bc6f1a29921369e47ba645f9aed2707a5b3 SHA512 ed92ca769276e66611de3cf9d44a03fd163516b973486ac5339dfe9cd9fbab8fb5f754799f59505f03aa5eb4ad175e804c6e61d0a5db63a558edf7ef1aff438c
+DIST xdebug-handler-2.0.1.tar.gz 14212 BLAKE2B 01200a86794145132a4c8d1b851a3131d73c23ca33d27fa9da26988f48a6c0df3552322f8fad0559ac00adf1605f35a65aa21591bc221d239ad2d8cbf4c303cd SHA512 6cc1d336a82f1edf6fb9dd317d0275c79754eb7a01fa34e0cc85c24b0a02363ccb2ff42e8b692d90077745f4db8409e7e66bef64f30a89b364eff71a4af7f4f1
diff --git a/dev-php/xdebug-handler/xdebug-handler-2.0.1.ebuild b/dev-php/xdebug-handler/xdebug-handler-2.0.1.ebuild
new file mode 100644
index 000000000000..ad9f7604ad52
--- /dev/null
+++ b/dev-php/xdebug-handler/xdebug-handler-2.0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Restart a CLI process without loading the xdebug extension"
+HOMEPAGE="https://github.com/composer/xdebug-handler"
+SRC_URI="https://github.com/composer/xdebug-handler/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader
+ >=dev-php/psr-log-1.0.2"
+
+src_install() {
+ insinto /usr/share/php/Composer/XdebugHandler
+ doins src/*.php "${FILESDIR}/autoload.php"
+ dodoc README.md
+}