summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-01-16 08:58:02 -0500
committerBrian Evans <grknight@gentoo.org>2019-01-16 08:58:02 -0500
commitd86bca3d8aeb9097256ba82fbb6217f9ade3d6d6 (patch)
treec19047a46aa9f6106b35f547749ed43cbf7b479e /dev-php
parentdev-python/pymysql: bump to v0.9.3 (diff)
downloadgentoo-d86bca3d8aeb9097256ba82fbb6217f9ade3d6d6.tar.gz
gentoo-d86bca3d8aeb9097256ba82fbb6217f9ade3d6d6.tar.bz2
gentoo-d86bca3d8aeb9097256ba82fbb6217f9ade3d6d6.zip
dev-php/pecl-apcu_bc: Revbump adding php7-3, drop php7-0
Package-Manager: Portage-2.3.56, Repoman-2.3.12 Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-apcu_bc/pecl-apcu_bc-1.0.4-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-php/pecl-apcu_bc/pecl-apcu_bc-1.0.4-r1.ebuild b/dev-php/pecl-apcu_bc/pecl-apcu_bc-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..e9ed00d7cc4e
--- /dev/null
+++ b/dev-php/pecl-apcu_bc/pecl-apcu_bc-1.0.4-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PHP_INI_NAME="bc_apc"
+PHP_EXT_NAME="apc"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_EXTRA_ECONF=""
+DOCS=( README.md )
+
+USE_PHP="php7-1 php7-2 php7-3"
+
+inherit php-ext-pecl-r3 multilib
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Provides APC backwards compatibility functions via APCu"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-php/pecl-apcu:7[php_targets_php7-1?,php_targets_php7-2?,php_targets_php7-3?]"
+RDEPEND="${DEPEND}"
+
+src_test() {
+ # This fixed version is necessary to have apcu load
+ # from the install before the tested apc.
+ # It is intentional to specify phpoptions twice.
+ # This mimics the Makefile.
+ local slot phpoptions
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ ln -s "${EXT_DIR}/apcu$(get_libname)" \
+ "modules/" || die
+ phpoptions=( -n -d extension_dir="${PHP_EXT_S}/modules"
+ -d extension=apcu$(get_libname)
+ -d extension=apc$(get_libname) )
+ NO_INTERACTION="yes" TEST_PHP_EXECUTABLE="${PHPCLI}" \
+ "${PHPCLI}" "${phpoptions[@]}" \
+ run-tests.php "${phpoptions[@]}" || die
+ done
+}