summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-02-01 19:08:49 +0100
committerThomas Deutschmann <whissi@gentoo.org>2021-02-01 20:15:50 +0100
commitdbd71774f6ea42b46e040061b0cf2bd7d1833a7d (patch)
tree89ab949bd3697b11a80601cd3a5942f73b599616 /dev-php
parentsys-auth/pambase: Version bump (v0210201) (diff)
downloadgentoo-dbd71774f6ea42b46e040061b0cf2bd7d1833a7d.tar.gz
gentoo-dbd71774f6ea42b46e040061b0cf2bd7d1833a7d.tar.bz2
gentoo-dbd71774f6ea42b46e040061b0cf2bd7d1833a7d.zip
dev-php/reactphp-promise: new package
New dependency of dev-php/composer-2. Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/reactphp-promise/Manifest1
-rw-r--r--dev-php/reactphp-promise/metadata.xml12
-rw-r--r--dev-php/reactphp-promise/reactphp-promise-2.8.0.ebuild48
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-php/reactphp-promise/Manifest b/dev-php/reactphp-promise/Manifest
new file mode 100644
index 000000000000..c11e1b030091
--- /dev/null
+++ b/dev-php/reactphp-promise/Manifest
@@ -0,0 +1 @@
+DIST reactphp-promise-2.8.0.tar.gz 17178 BLAKE2B 43e5a9eef0f774ec4de7be44fbab300dfd78a23b21de2acbb39e44af49ee95b2532f66b711acc4ee152522d4725e1e29f9abae20d0ac2e18fba3dbb3f615cc5e SHA512 8c882c96b47cc53f791de964303014feb00a73594a510287ea352ff619a8432d88f4c094523d4de98234f985f7351cd244bb094484a257aa36357e85eb0ee62e
diff --git a/dev-php/reactphp-promise/metadata.xml b/dev-php/reactphp-promise/metadata.xml
new file mode 100644
index 000000000000..3ea1553292f1
--- /dev/null
+++ b/dev-php/reactphp-promise/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">reactphp/promise</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php/reactphp-promise/reactphp-promise-2.8.0.ebuild b/dev-php/reactphp-promise/reactphp-promise-2.8.0.ebuild
new file mode 100644
index 000000000000..df2600171222
--- /dev/null
+++ b/dev-php/reactphp-promise/reactphp-promise-2.8.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="promise"
+
+DESCRIPTION="A lightweight implementation of CommonJS Promises/A for PHP"
+HOMEPAGE="https://reactphp.org/promise/"
+SRC_URI="https://github.com/reactphp/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="dev-php/theseer-Autoload"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-7.2:*"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ default
+
+ phpab \
+ --output src/autoload.php \
+ --template fedora2 \
+ --basedir src \
+ src \
+ || die
+
+cat >> src/autoload.php <<EOF || die "failed to extend autoload.php"
+
+// Dependencies
+\Fedora\Autoloader\Dependencies::required([
+ '/usr/share/php/React/Promise/functions.php'
+]);
+EOF
+}
+
+src_install() {
+ insinto /usr/share/php/React/Promise
+ doins -r src/*
+
+ einstalldocs
+}