summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2021-08-27 09:43:13 -0400
committerBrian Evans <grknight@gentoo.org>2021-08-27 09:43:13 -0400
commitde80d58d717f883b7f2ca01a754be9dbe6b45544 (patch)
treeae2bcb383b902a520bbe64e6154144256837a047 /dev-php
parentsys-apps/debianutils: bump to v5.4 (diff)
downloadgentoo-de80d58d717f883b7f2ca01a754be9dbe6b45544.tar.gz
gentoo-de80d58d717f883b7f2ca01a754be9dbe6b45544.tar.bz2
gentoo-de80d58d717f883b7f2ca01a754be9dbe6b45544.zip
dev-php/pecl-eio: Version bump for 3.0.0_rc2
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-eio/Manifest1
-rw-r--r--dev-php/pecl-eio/pecl-eio-3.0.0_rc2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-php/pecl-eio/Manifest b/dev-php/pecl-eio/Manifest
index a7cfe5a8314e..e394309ac89c 100644
--- a/dev-php/pecl-eio/Manifest
+++ b/dev-php/pecl-eio/Manifest
@@ -1 +1,2 @@
DIST eio-2.0.4.tgz 74118 BLAKE2B 0228f0ca91ed6410614242e7ea1ddadaa1d1aa8211b3ea6f730c0711e4339bc158d661c5addee685d750a51e654874d35a04cf011d2a02ad06ab3f249b893753 SHA512 a74464752af5792c527b9149a7edff574952cac0b5b09e1e7ff3b7c0a2cc88ab171d916d94d508b9f92aa40bd5262a5b9f8d4ba239908f13ebcb89c6513da4d0
+DIST eio-3.0.0RC2.tgz 89591 BLAKE2B 7923f8715870cfd744148980e3ad6de8373384d85e45abc687be2cde22fd425a33b8c80fbd1226e23dbac417533826dfbf639fed751bfc2a88e118750e38d626 SHA512 23e7d88720222ac3f58015ba140e3338e100cf72cf64276fd7e0f0d63a5e50f878ab0a4a742eac7b51484c56ee438fcc3f7cbf7b1da5db44e0178a5098a4a6ae
diff --git a/dev-php/pecl-eio/pecl-eio-3.0.0_rc2.ebuild b/dev-php/pecl-eio/pecl-eio-3.0.0_rc2.ebuild
new file mode 100644
index 000000000000..32a585eab37d
--- /dev/null
+++ b/dev-php/pecl-eio/pecl-eio-3.0.0_rc2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+MY_PN="${PN/pecl-}"
+MY_PV="${PV/_rc/RC}"
+MY_P="${MY_PN}-${MY_PV}"
+PHP_EXT_NAME="eio"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_PECL_FILENAME="${MY_P}.tgz"
+PHP_EXT_S="${WORKDIR}/${MY_P}"
+DOCS=( README.md )
+
+USE_PHP="php7-3 php7-4 php8-0"
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="PHP-3.01"
+
+DESCRIPTION="PHP wrapper for libeio library"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE="debug"
+
+S="${PHP_EXT_S}"
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=("--with-eio" "$(use_enable debug eio-debug)" )
+ php-ext-source-r3_src_configure
+}