summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-03-09 16:05:04 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-03-09 16:05:04 +0100
commite2093ec2622b62746302c1cc448d05e1550d16bf (patch)
tree8dd7d76bb6656b2800ff6359e75ff3551350df97 /dev-php
parentdev-python/pyphen: bump to v0.9.5 (diff)
downloadgentoo-e2093ec2622b62746302c1cc448d05e1550d16bf.tar.gz
gentoo-e2093ec2622b62746302c1cc448d05e1550d16bf.tar.bz2
gentoo-e2093ec2622b62746302c1cc448d05e1550d16bf.zip
dev-php/swoole: bump to v4.4.16
Package-Manager: Portage-2.3.91, Repoman-2.3.20 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/swoole/Manifest1
-rw-r--r--dev-php/swoole/swoole-4.4.16.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-php/swoole/Manifest b/dev-php/swoole/Manifest
index b73f5330507e..48df9f82e5e5 100644
--- a/dev-php/swoole/Manifest
+++ b/dev-php/swoole/Manifest
@@ -2,3 +2,4 @@ DIST swoole-4.2.13.tgz 1305634 BLAKE2B bb30180f7ca7b024a2aab8aff1149f6b19035315c
DIST swoole-4.4.12.tgz 1436554 BLAKE2B cc9e64e108aa9b393265708a6922f53824c2e9941c0f47f4f6aacf93239829381cdf4625af8f30e2ca8ceb1663047c6be8b2d7808dbc29d27100135288f7ac85 SHA512 8899bb048b85c048903c80fe1af045ea4f82a25b3b4fd9995d51c8a2ab144306f9f5651276776e3f6a29c83322fb0aeee2822d131247070fe9e2e87b26f2e0e9
DIST swoole-4.4.14.tgz 1440095 BLAKE2B 8a893604a84f750b95bb63a3c6ce9869a80a700b58e744e0da588dcdb88b9d9ae8fa5b73548cc182e255d7fe4e49139c3da9bcec40a54af94c35d355ee4cbfe0 SHA512 73b598069d38dcc3201a31fdd93c1bcf0ce31ab5399bade8c31f6decae25ef6e9c0aefe0412409158c1dd0fe502751c8e669e0a34561cb1b36448366708572c6
DIST swoole-4.4.15.tgz 1454897 BLAKE2B 38f804e5f2f41ba2bc32ac2e6fd7be3e03f7a361487d7dad41bdc2ee3f2489d41824f60a841de1e3dea0cbf105d11dc1b5c2225ae49a02155604bc09c990ed61 SHA512 5ad797b38a20cfa17b0aa1fc5ab4f6446b84debb38babc05630e07833895401c778f1c6cf9eb32d7204b02c0e170ba6e613f356a054baa29ac511c19ce59620f
+DIST swoole-4.4.16.tgz 1457270 BLAKE2B 4b65270aa1014ea68cadae8eb021d37498dc3fe0bf2d681c95bf7113928138bc26ab73f3be91185eb5ecebcb4940906814913c7908c87592aafd33fbc1820bf7 SHA512 7be4705967ed6b7a955f679f8c39585d34dc8c87ba608ac3ae2b0fc3cae9513d9639c8e9aac4278ce85acc215b500044626aab9b2aac725c9ffaef72dfb02dd7
diff --git a/dev-php/swoole/swoole-4.4.16.ebuild b/dev-php/swoole/swoole-4.4.16.ebuild
new file mode 100644
index 000000000000..146edf124e9f
--- /dev/null
+++ b/dev-php/swoole/swoole-4.4.16.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PHP_EXT_NAME="swoole"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_SAPIS="cli"
+DOCS=( README.md )
+
+USE_PHP="php7-1 php7-2 php7-3 php7-4"
+
+inherit php-ext-pecl-r3
+
+HOMEPAGE="https://www.swoole.co.uk"
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Event-driven asynchronous & concurrent & coroutine networking engine"
+LICENSE="Apache-2.0"
+SLOT="0"
+# Tests can hang. Disable until this no longer happens
+RESTRICT="test"
+
+DEPEND="
+ app-arch/brotli:0=
+ dev-libs/libaio
+ dev-libs/boost:0=
+ dev-libs/libpcre
+ sys-libs/zlib:0=
+ http2? ( net-libs/nghttp2:0= )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ php_targets_php7-1? ( dev-lang/php:7.1[cli,sockets?] )
+ php_targets_php7-2? ( dev-lang/php:7.2[cli,sockets?] )
+ php_targets_php7-3? ( dev-lang/php:7.3[cli,sockets?] )
+ php_targets_php7-4? ( dev-lang/php:7.4[cli,sockets?] )
+ mysql? (
+ php_targets_php7-1? ( dev-lang/php:7.1[mysql,mysqli(+)] )
+ php_targets_php7-2? ( dev-lang/php:7.2[mysql,mysqli(+)] )
+ php_targets_php7-3? ( dev-lang/php:7.3[mysql,mysqli(+)] )
+ php_targets_php7-4? ( dev-lang/php:7.4[mysql,mysqli(+)] )
+ )
+"
+
+RDEPEND="${DEPEND}"
+
+IUSE="debug http2 libressl mysql sockets ssl"
+
+src_configure() {
+ # JEMalloc not included as it refuses to find a ${EROOT}/usr/includes/jemalloc subdirectory
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-swoole
+ $(use_enable debug)
+ $(use_enable http2)
+ $(use_enable mysql mysqlnd)
+ $(use_enable ssl openssl)
+ $(use_with ssl openssl-dir "${EROOT}/usr")
+ $(use_enable sockets)
+ )
+
+ php-ext-source-r3_src_configure
+}
+
+src_test() {
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ [[ -f tests/template.phpt ]] && rm tests/template.phpt
+ SKIP_ONLINE_TESTS="yes" NO_INTERACTION="yes" emake test
+ done
+}