summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-01-07 14:12:59 -0500
committerMichael Orlitzky <mjo@gentoo.org>2017-01-07 14:23:27 -0500
commite491aa65a5b0a89dda0c76fdac559d192c96b6ed (patch)
tree77cd2ea384bd29f90d7f86be1127d4fadd45b0d5 /dev-php
parentdev-php/PEAR-HTTP_Request2: remove unused versions 2.0.0 and 2.1.1. (diff)
downloadgentoo-e491aa65a5b0a89dda0c76fdac559d192c96b6ed.tar.gz
gentoo-e491aa65a5b0a89dda0c76fdac559d192c96b6ed.tar.bz2
gentoo-e491aa65a5b0a89dda0c76fdac559d192c96b6ed.zip
dev-php/phing: new unbundled version 2.16.0.
This new version is a major overhaul of the ebuild. We start with an update to EAPI=6, and then everything else is basically new. The previous version installed a single compressed PHAR archive, while now we actually install the source, documentation, examples, and executables -- all in the correct places. Some dependencies were fixed, and there are new USE flags for a couple of optional dependencies (eventually there should be more flags, rather than rely on USE=minimal). Upstream's metadata was updated, too. Unfortunately, many features of this package will not work. Since phpDocumentor and phpunit are still packaged as PHAR archives, phing cannot make use of their libraries. This is not a new problem, however, so it is acceptable to allow in in the new version. Gentoo-Bug: 604954 Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/phing/Manifest2
-rw-r--r--dev-php/phing/files/autoload.php14
-rw-r--r--dev-php/phing/metadata.xml17
-rw-r--r--dev-php/phing/phing-2.10.1.ebuild46
-rw-r--r--dev-php/phing/phing-2.16.0.ebuild58
5 files changed, 86 insertions, 51 deletions
diff --git a/dev-php/phing/Manifest b/dev-php/phing/Manifest
index 7688dea01ea7..c937f4417086 100644
--- a/dev-php/phing/Manifest
+++ b/dev-php/phing/Manifest
@@ -1 +1 @@
-DIST phing-2.10.1.phar 851181 SHA256 7df436757a0a9427e1983af4847abfbadc92a6b4535b1e60b69bacfb139da6f8 SHA512 026b08945f189be30b29268aa9a8fb889975addd385e7087cb3f1e1bd2b5a01cabddff47fa52d197bbc520c4d5ad6e47edaa5446300e0baeebff24165f7c4246 WHIRLPOOL ae60318f2551510ca40b011f538849928256d2e081d6d910f14f519db2838edf0925256df2a33dee4d37797d7b670e8761e3a93340fe1d44ad951b841fa08492
+DIST phing-2.16.0.tgz 4142331 SHA256 86276306cbb5e692951199fc658a545eec38279fe1e4b1823b71b2bd08715bab SHA512 f738d08a195d69c32a035dd3739e0cbc56946173dc31e8fdc8fc07664139b2b97832a6bbb527785e5dfe025530c364a1ed1075a0b77baecfc2395ec78549ba72 WHIRLPOOL 263510867e1cc4896f075b4d0b75da7f0dbbaa9acba202adacfd0524ecf8a57500a934c35a3b21384ccb892376cf2cfe87d1d4416d097c0896b51ccb02f0dbca
diff --git a/dev-php/phing/files/autoload.php b/dev-php/phing/files/autoload.php
new file mode 100644
index 000000000000..437a7dc7ee1e
--- /dev/null
+++ b/dev-php/phing/files/autoload.php
@@ -0,0 +1,14 @@
+<?php
+$vendor_dir = '/usr/share/php';
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+ require_once("${vendor_dir}/Fedora/Autoloader/autoload.php");
+}
+
+/*
+ At least for the moment, we don't need to autoload the Phing classes
+ themselves, because the "require" statements are all still there.
+*/
+
+\Fedora\Autoloader\Dependencies::required(
+ array("${vendor_dir}/Symfony/Component/Yaml/autoload.php")
+);
diff --git a/dev-php/phing/metadata.xml b/dev-php/phing/metadata.xml
index b86acf66c756..104818de2b2f 100644
--- a/dev-php/phing/metadata.xml
+++ b/dev-php/phing/metadata.xml
@@ -1,8 +1,17 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>php-bugs@gentoo.org</email>
- <name>PHP</name>
- </maintainer>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">phingofficial/phing</remote-id>
+ </upstream>
+ <use>
+ <flag name="zip">
+ Support zip archives by requiring said support in
+ <pkg>dev-lang/php</pkg>.
+ </flag>
+ </use>
</pkgmetadata>
diff --git a/dev-php/phing/phing-2.10.1.ebuild b/dev-php/phing/phing-2.10.1.ebuild
deleted file mode 100644
index ecc1044d8500..000000000000
--- a/dev-php/phing/phing-2.10.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-DESCRIPTION="PHP project build system based on Apache Ant"
-HOMEPAGE="http://www.phing.info/"
-SRC_URI="http://www.phing.info/get/phing-${PV}.phar"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+minimal"
-
-DEPEND=""
-RDEPEND="!minimal? ( dev-php/phpDocumentor
- dev-php/PHP_CodeCoverage
- >=dev-php/PEAR-HTTP_Request2-2.1.1
- >=dev-php/PEAR-PEAR_PackageFileManager-1.5.2
- >=dev-php/PEAR-VersionControl_SVN-0.3.0_alpha1
- >=dev-php/phpmd-1.1.0
- >=dev-php/phpunit-4.0
- >=dev-php/xdebug-2.0.5
- >=dev-php/simpletest-1.0.1_beta2 )
- dev-lang/php:*[cli,phar,xml,xslt]
- "
-
-S=${WORKDIR}
-
-src_unpack() { :; }
-
-src_install() {
- insinto /usr/share/php/phing
- insopts -m755
- newins "${DISTDIR}/${P}.phar" phing.phar
- dosym /usr/share/php/phing/phing.phar /usr/bin/phing
-}
-
-pkg_postinst() {
- if use minimal; then
- elog "You have enabled the minimal USE flag. If you want to use features"
- elog "from xdebug, phpunit, simpletest and more, disable the"
- elog "USE flag or emerge the packages manually"
- fi
-}
diff --git a/dev-php/phing/phing-2.16.0.ebuild b/dev-php/phing/phing-2.16.0.ebuild
new file mode 100644
index 000000000000..c46dc8178220
--- /dev/null
+++ b/dev-php/phing/phing-2.16.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="PHP project build system based on Apache Ant"
+HOMEPAGE="http://www.phing.info/"
+SRC_URI="http://www.phing.info/get/${P}.tgz"
+
+LICENSE="FDL-1.3 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples minimal zip"
+
+RDEPEND="dev-lang/php:*[cli,xml,xslt,zip?]
+ dev-php/symfony-yaml
+ !minimal? (
+ dev-php/PEAR-HTTP_Request2
+ dev-php/PEAR-PEAR_PackageFileManager
+ dev-php/PEAR-VersionControl_SVN
+ dev-php/PHP_CodeCoverage
+ dev-php/phpDocumentor
+ dev-php/phpmd
+ dev-php/phpunit
+ dev-php/simpletest
+ dev-php/xdebug
+ )"
+
+S="${WORKDIR}"
+
+src_install() {
+ dodoc CHANGELOG.md CREDITS.md README.md
+ dodoc -r docs/docbook5/en/output/hlhtml
+ use doc && dodoc -r docs/api
+ use examples && dodoc -r docs/example
+
+ # Install the executable (and the PHP file it wraps) outside of the
+ # PHP include directory, since nobody should be including it.
+ exeinto "/usr/share/${PN}/bin"
+ doexe "bin/${PN}"
+ insinto "/usr/share/${PN}/bin"
+ doins "bin/${PN}.php"
+ dosym "/usr/share/${PN}/bin/${PN}" "/usr/bin/${PN}"
+
+ # Phing tries to get the version number from this file.
+ insinto "/usr/share/${PN}/etc"
+ doins etc/VERSION.TXT
+
+ # The executable will only look for autoload.php in one place, so we
+ # create an (otherwise pointless) vendor directory to house it.
+ insinto "/usr/share/${PN}/vendor"
+ doins "${FILESDIR}/autoload.php"
+
+ # But install the library under /usr/share/php.
+ insinto "/usr/share/php"
+ doins -r "classes/${PN}"
+}