summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-01-07 12:38:48 -0500
committerMichael Orlitzky <mjo@gentoo.org>2017-01-07 14:23:26 -0500
commitf3a433cbfe7cfd399504f5b4cd47ceccfde91660 (patch)
tree82421d10a91ebafdc0a8dc18331d72296eecbb4a /dev-php
parentdev-games/clanlib: Version bump to 4.0.0 (diff)
downloadgentoo-f3a433cbfe7cfd399504f5b4cd47ceccfde91660.tar.gz
gentoo-f3a433cbfe7cfd399504f5b4cd47ceccfde91660.tar.bz2
gentoo-f3a433cbfe7cfd399504f5b4cd47ceccfde91660.zip
dev-php/agavi: new version 1.0.8.
This new version fixes a lot of problems caused by the old PEAR build system. First, we don't need the PEAR dependencies, so they've been dropped. The docs are installed in the correct place, and the build system won't crash if you eselect the wrong version of PHP. The ebuild has been updated to EAPI=6, and has a few more USE flags to control its dependencies. Even the executable (which requires phing) is now optional. But beware: this package is mostly broken out-of-the-box. The "agavi" executable requires some code from dev-php/phing, but the phing ebuild was rewritten to use a PHAR, and no longer installs any source code. Since the old version of phing (a) would not build for me and (b) should have exactly the same problem, I don't consider that a blocker for this new version. Gentoo-Bug: 604954 Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/agavi/Manifest2
-rw-r--r--dev-php/agavi/agavi-1.0.7.ebuild40
-rw-r--r--dev-php/agavi/agavi-1.0.8.ebuild40
-rwxr-xr-xdev-php/agavi/files/agavi-executable14
-rw-r--r--dev-php/agavi/metadata.xml18
5 files changed, 69 insertions, 45 deletions
diff --git a/dev-php/agavi/Manifest b/dev-php/agavi/Manifest
index 032184971862..0f3f747c0403 100644
--- a/dev-php/agavi/Manifest
+++ b/dev-php/agavi/Manifest
@@ -1 +1 @@
-DIST 1.0.7.tgz 2064782 SHA256 46cb0f9a4f9381ec06e0b82b11683930ac732140188b2e841d3e73d2574173f7 SHA512 157d1213b8279a4edd1706f66334bc60889b51b1e71c6d398b74272c72ff47f540f7c7eaf3b1c57c0d6e4397c647f80264a74fa5929d5521ec67799aa9f58156 WHIRLPOOL 999d7275a3a42dd1abdec017597015c6c500abdf80a9b0d40ff1fab3ff19694225f9f080eae7389e7fedf97ef46c96587f95e78b9793c7ec53c1561d5beee9ff
+DIST agavi-1.0.8.tgz 2074126 SHA256 9770662721b9f59ca2324a02ca9f698a08b517beeae30cc5e14677b175440b9b SHA512 9e75ef0be455e329db8b2389d7fd7a7acb25d04dda6c31dea15496dc4e24ab17cf0e44e199d0c2a9fb11987331d582cf0c700adee815cac7276c32643b9183ee WHIRLPOOL 273c347182669e0d2f345ee5353a529edfff46eec645f069228e3fc71ca65222e3cb1214c70bbaa433545ee1d0ce65c2b2f2d24605ee399690576cbb95410e83
diff --git a/dev-php/agavi/agavi-1.0.7.ebuild b/dev-php/agavi/agavi-1.0.7.ebuild
deleted file mode 100644
index b0bee74d27c0..000000000000
--- a/dev-php/agavi/agavi-1.0.7.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-inherit php-pear-lib-r1
-
-DESCRIPTION="PHP5 MVC Application Framework"
-HOMEPAGE="http://www.agavi.org/"
-SRC_URI="http://www.agavi.org/download/${PV}.tgz"
-
-LICENSE="LGPL-2.1+ icu unicode ZLIB public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-# currently fails to install with dev-php/PEAR-PEAR_PackageFileManager-1.7.0
-DEPEND="
- >=dev-lang/php-5[xml]
- >=dev-php/PEAR-PEAR-1.6.2-r1
- >=dev-php/phing-2.4[-minimal]
- <dev-php/PEAR-PEAR_PackageFileManager-1.7.0
- "
-
-RDEPEND="
- >=dev-php/phing-2.4
- "
-
-src_compile() {
- phing package-pear || die "failed to build pear package"
-}
-
-src_install() {
- cd "${WORKDIR}"
- mv "${S}" "${WORKDIR}"/${PV}
- cp -pPR "${WORKDIR}"/${PV}/pear-build/* "${WORKDIR}"/
- cd "${S}"
- php-pear-lib-r1_src_install
-}
diff --git a/dev-php/agavi/agavi-1.0.8.ebuild b/dev-php/agavi/agavi-1.0.8.ebuild
new file mode 100644
index 000000000000..73be8db190ae
--- /dev/null
+++ b/dev-php/agavi/agavi-1.0.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="PHP MVC application framework"
+HOMEPAGE="http://www.agavi.org/"
+SRC_URI="http://www.agavi.org/download/${PV}.tgz -> ${P}.tgz"
+LICENSE="BSD LGPL-2.1+ icu unicode public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples +executable iconv session soap xmlrpc"
+
+RDEPEND="dev-lang/php[iconv?,session?,soap?,xml,xmlrpc?]
+ executable? ( dev-php/phing )"
+
+DOCS=(
+ API_CHANGELOG
+ CHANGELOG
+ CHANGELOG-0.9
+ CHANGELOG-0.10
+ CHANGELOG-0.11
+ CONTRIBUTING.md
+ README.md
+ RELEASE_NOTES
+ RELEASE_NOTES-0.9
+ RELEASE_NOTES-0.10
+ RELEASE_NOTES-0.11
+ UPGRADING
+)
+
+src_install() {
+ einstalldocs
+ use executable && newbin "${FILESDIR}/${PN}-executable" "${PN}"
+ use examples && dodoc -r samples
+
+ insinto "/usr/share/php/${PN}"
+ doins -r src/*
+}
diff --git a/dev-php/agavi/files/agavi-executable b/dev-php/agavi/files/agavi-executable
new file mode 100755
index 000000000000..06405d6ca2e7
--- /dev/null
+++ b/dev-php/agavi/files/agavi-executable
@@ -0,0 +1,14 @@
+#!/bin/sh
+#
+# A (heavily) modified version of the agavi-dist script shipped with
+# the Agavi package.
+#
+
+# Set this to the path to the Agavi installation's source directory. This is
+# the directory that contains the `agavi.php' file.
+AGAVI_SOURCE_DIRECTORY="/usr/share/php/agavi"
+
+php -d memory_limit=2G \
+ -f "${AGAVI_SOURCE_DIRECTORY}/build/agavi/script/agavi.php" \
+ -- \
+ --agavi-source-directory "${AGAVI_SOURCE_DIRECTORY}" "$@"
diff --git a/dev-php/agavi/metadata.xml b/dev-php/agavi/metadata.xml
index b86acf66c756..fb37a3a38209 100644
--- a/dev-php/agavi/metadata.xml
+++ b/dev-php/agavi/metadata.xml
@@ -1,8 +1,18 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>php-bugs@gentoo.org</email>
- <name>PHP</name>
- </maintainer>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <use>
+ <flag name="executable">
+ Install the "agavi" executable used to manage projects. This
+ requires <pkg>dev-php/phing</pkg>, and may be omitted if you are
+ (for example) deploying an existing site to a production server.
+ </flag>
+ </use>
+ <upstream>
+ <remote-id type="github">agavi/agavi</remote-id>
+ </upstream>
</pkgmetadata>