summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-06-13 20:15:50 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-06-13 20:19:36 +0200
commitfd5a77f9aa4f823323966965712853c4e8dce5fa (patch)
tree9dd23b1b296aec288cbd186937248262cb31d6f9 /dev-php
parentapp-arch/rar: drop old (diff)
downloadgentoo-fd5a77f9aa4f823323966965712853c4e8dce5fa.tar.gz
gentoo-fd5a77f9aa4f823323966965712853c4e8dce5fa.tar.bz2
gentoo-fd5a77f9aa4f823323966965712853c4e8dce5fa.zip
dev-php/webmozart-assert: bump to v1.10.0
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/webmozart-assert/Manifest1
-rw-r--r--dev-php/webmozart-assert/webmozart-assert-1.10.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-php/webmozart-assert/Manifest b/dev-php/webmozart-assert/Manifest
index 6519cc55db61..9c3f8cb75b6b 100644
--- a/dev-php/webmozart-assert/Manifest
+++ b/dev-php/webmozart-assert/Manifest
@@ -1,2 +1,3 @@
+DIST webmozart-assert-1.10.0.tar.gz 17318 BLAKE2B e4ef61655deb639f22e40cf37a43820b7cebe455d5dc157f68ee9ab4720a0203233a744f6a2cc8ab8c755e9e017f478beb31cbb52de8df0e8f24da86de76b28f SHA512 e847da4f137f90da2016ea6935e479d7ea11d8944b2b9932cd0fea534f2d789c2a1c4ed7db3837a517f0074fb6ca58af9d45bc2aeb6d3bebc01f795a3be9811f
DIST webmozart-assert-1.2.0.tar.gz 11866 BLAKE2B 86cb0f299efff9822ea79964153b17337eac3e17a968b5201680186cfb3f6721b2ca561e041e71b304c6d29d227b446f7f52b65d5a6fc490c8535dd4fee0160c SHA512 36bae648cfe5bbd258d738574a820ea3de2e95b59700d556dd5eadbb1657bc09a7e73000e3436d020e060ecd2a99944199795f315a278acbeeea90570b0a4a22
DIST webmozart-assert-1.4.0.tar.gz 9241 BLAKE2B bbe5d42732c99700f11db6a3a8b6d6753d60b3e6fbfb8412383459199139f31e3ec55e4abee03295adea19c9c48edb0f13a11597b654fdd0de0a7823ed545586 SHA512 1ed2328de800bb98b7c00264009182934006ae146d86aa313f3478b9f3a7e6eed9dee026ed80d18393724840711ecd9891ee34178676470d12cac8124f819309
diff --git a/dev-php/webmozart-assert/webmozart-assert-1.10.0.ebuild b/dev-php/webmozart-assert/webmozart-assert-1.10.0.ebuild
new file mode 100644
index 000000000000..5ceccfa33d0c
--- /dev/null
+++ b/dev-php/webmozart-assert/webmozart-assert-1.10.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PN="${PN/webmozart-//}"
+
+DESCRIPTION="Assertions to validate method input/output with nice error messages"
+HOMEPAGE="https://github.com/webmozart/assert"
+SRC_URI="https://github.com/webmozart/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-5.6:*[ctype]"
+
+src_install() {
+ insinto /usr/share/php/Webmozart/Assert
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+}