summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2021-08-27 10:24:04 -0400
committerBrian Evans <grknight@gentoo.org>2021-08-27 10:34:00 -0400
commitff60a488311ed77b89403d50920a76390331b01d (patch)
treebe9b6665653e9727213a1720e072caf1554344aa /dev-php
parentnet-dialup/ppp: Fixed "|| die" call (diff)
downloadgentoo-ff60a488311ed77b89403d50920a76390331b01d.tar.gz
gentoo-ff60a488311ed77b89403d50920a76390331b01d.tar.bz2
gentoo-ff60a488311ed77b89403d50920a76390331b01d.zip
dev-php/pecl-ps: Revbump to remove old dependencies and targets
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-ps/pecl-ps-1.4.1-r1.ebuild25
-rw-r--r--dev-php/pecl-ps/pecl-ps-1.4.1.ebuild49
2 files changed, 25 insertions, 49 deletions
diff --git a/dev-php/pecl-ps/pecl-ps-1.4.1-r1.ebuild b/dev-php/pecl-ps/pecl-ps-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..34f9154d7935
--- /dev/null
+++ b/dev-php/pecl-ps/pecl-ps-1.4.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PHP_EXT_NAME="ps"
+USE_PHP="php7-3 php7-4"
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="PHP extension for creating PostScript files"
+LICENSE="BSD"
+SLOT="7"
+IUSE="examples"
+
+DEPEND="dev-libs/pslib"
+RDEPEND="${DEPEND}"
+PHP_EXT_ECONF_ARGS=""
+
+src_test() {
+ # tests/004.phpt depends on set numeric format
+ LC_ALL=C php-ext-pecl-r3_src_test
+}
diff --git a/dev-php/pecl-ps/pecl-ps-1.4.1.ebuild b/dev-php/pecl-ps/pecl-ps-1.4.1.ebuild
deleted file mode 100644
index fd04378b47c9..000000000000
--- a/dev-php/pecl-ps/pecl-ps-1.4.1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PHP_EXT_NAME="ps"
-USE_PHP="php5-6 php7-1 php7-2 php7-3 php7-4"
-
-inherit php-ext-pecl-r3
-
-# Only really build for >=7.0
-USE_PHP="php7-1 php7-2 php7-3 php7-4"
-
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-
-DESCRIPTION="PHP extension for creating PostScript files"
-LICENSE="BSD"
-SLOT="7"
-IUSE="examples"
-
-DEPEND="
- php_targets_php7-1? ( dev-libs/pslib )
- php_targets_php7-2? ( dev-libs/pslib )
- php_targets_php7-3? ( dev-libs/pslib )
- php_targets_php7-4? ( dev-libs/pslib )
-"
-RDEPEND="${DEPEND} php_targets_php5-6? ( dev-php/pecl-ps:0[php_targets_php5-6] )"
-PHP_EXT_ECONF_ARGS=""
-
-src_prepare() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
- php-ext-source-r3_src_prepare
- else
- default_src_prepare
- fi
-}
-
-src_install() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
- php-ext-pecl-r3_src_install
- fi
-}
-
-src_test() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
- # tests/004.phpt depends on set numeric format
- LC_ALL=C php-ext-pecl-r3_src_test
- fi
-}