summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-07-12 19:29:51 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-07-13 01:04:05 +0200
commit3bc7df40dfde35b24f61409d40dddfc88383bd94 (patch)
tree2a9a33977eac18ea295a3de79b1cf219f2976263 /dev-python/BitVector/BitVector-3.4.8.ebuild
parentdev-python/bitarray: add amd64-fbsd keyword. (diff)
downloadgentoo-3bc7df40dfde35b24f61409d40dddfc88383bd94.tar.gz
gentoo-3bc7df40dfde35b24f61409d40dddfc88383bd94.tar.bz2
gentoo-3bc7df40dfde35b24f61409d40dddfc88383bd94.zip
dev-python/BitVector: version bump.
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'dev-python/BitVector/BitVector-3.4.8.ebuild')
-rw-r--r--dev-python/BitVector/BitVector-3.4.8.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/BitVector/BitVector-3.4.8.ebuild b/dev-python/BitVector/BitVector-3.4.8.ebuild
new file mode 100644
index 000000000000..4286029d351f
--- /dev/null
+++ b/dev-python/BitVector/BitVector-3.4.8.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure-Python memory-efficient packed representation for bit arrays"
+HOMEPAGE="https://engineering.purdue.edu/kak/dist/ https://pypi.org/project/BitVector/"
+SRC_URI="https://engineering.purdue.edu/kak/dist/${P}.tar.gz"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" TestBitVector/Test.py || die "Tests fail with ${EPYTHON}"
+}