summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-15 07:12:50 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-15 08:26:57 +0100
commit0adf0b4d19f151b52fa93bcb96bac73be544fe34 (patch)
tree4bb2f036043ae10d7473ffcb7a7580bed6ba8e1f /dev-python/Faker
parentdev-python/mypy: Bump to 0.991 (diff)
downloadgentoo-0adf0b4d19f151b52fa93bcb96bac73be544fe34.tar.gz
gentoo-0adf0b4d19f151b52fa93bcb96bac73be544fe34.tar.bz2
gentoo-0adf0b4d19f151b52fa93bcb96bac73be544fe34.zip
dev-python/Faker: Bump to 15.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Faker')
-rw-r--r--dev-python/Faker/Faker-15.3.2.ebuild34
-rw-r--r--dev-python/Faker/Manifest1
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-15.3.2.ebuild b/dev-python/Faker/Faker-15.3.2.ebuild
new file mode 100644
index 000000000000..7547e146fdbe
--- /dev/null
+++ b/dev-python/Faker/Faker-15.3.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="
+ https://github.com/joke2k/faker/
+ https://pypi.org/project/Faker/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ !dev-ruby/faker
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/Faker/Manifest b/dev-python/Faker/Manifest
index ca03d5bbbdd4..9379c24c132f 100644
--- a/dev-python/Faker/Manifest
+++ b/dev-python/Faker/Manifest
@@ -1 +1,2 @@
DIST Faker-15.3.1.tar.gz 1598695 BLAKE2B 8c9d8ec18cf8505eb3ca00feb0e7cea78db2f6f5b8dd4b0a65cc600b0cf57a96c174a6f0f2f99f67dab873ad6afc63f858b5f0efe672583d055eb69d59a86104 SHA512 8dce318ee0e8959b7f7da4b5fda792476a7b4f8bc22a2acead29131e0f6c97fb0b84522cc2865264276f65606e8559ae3213f4671e4c701301845986920ecf9d
+DIST Faker-15.3.2.tar.gz 1598951 BLAKE2B 6f1c53933639a478aa6db933b26e326561b654cbb3d7182c7d8b1add50aaa4089ebf001553e95657baa2f434516148e40417c0265043d2a50f8e86c73556f82f SHA512 96489fd02cc16ff0a31a0f165805aa4508e2f3e04552f2008b92f211c8645e37ee23a8181838f851114906e2df0da19a95c38889e6afab5d1c7cf090a9235e17