summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-03 06:43:42 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-03 06:43:42 +0200
commit521e3d0c4d04504edf4beb90523033e15351014d (patch)
tree0b51ce2379da6fe1647434a696f06fa6f3cfa3bc /dev-python/Levenshtein/Levenshtein-0.21.0-r1.ebuild
parentxfce-base/libxfce4ui: Remove old (diff)
downloadgentoo-521e3d0c4d04504edf4beb90523033e15351014d.tar.gz
gentoo-521e3d0c4d04504edf4beb90523033e15351014d.tar.bz2
gentoo-521e3d0c4d04504edf4beb90523033e15351014d.zip
dev-python/Levenshtein: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Levenshtein/Levenshtein-0.21.0-r1.ebuild')
-rw-r--r--dev-python/Levenshtein/Levenshtein-0.21.0-r1.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/Levenshtein/Levenshtein-0.21.0-r1.ebuild b/dev-python/Levenshtein/Levenshtein-0.21.0-r1.ebuild
deleted file mode 100644
index 6f5b0a6fbfa3..000000000000
--- a/dev-python/Levenshtein/Levenshtein-0.21.0-r1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-# custom wrapper over setuptools
-DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Functions for fast computation of Levenshtein distance, and edit operations"
-HOMEPAGE="
- https://pypi.org/project/Levenshtein/
- https://github.com/maxbachmann/Levenshtein/
-"
-SRC_URI="
- https://github.com/maxbachmann/Levenshtein/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-DEPEND="
- <dev-cpp/rapidfuzz-cpp-2
- >=dev-cpp/rapidfuzz-cpp-1.7.0
-"
-RDEPEND="
- <dev-python/rapidfuzz-4.0.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- >=dev-python/scikit-build-0.13.0[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # sterilize build flags
- sed -i -e '/CMAKE_INTERPROCEDURAL_OPTIMIZATION/d' CMakeLists.txt || die
-
- distutils-r1_src_prepare
-}