summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-28 17:18:16 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-28 17:23:54 +0200
commit1352d0e851be7a3e5f3f0e629835737b6bbc1400 (patch)
tree3882540b6661722de24da4a5c6009101d6a9f347 /dev-python/Levenshtein/Levenshtein-0.22.0.ebuild
parentdev-python/numexpr: Remove old (diff)
downloadgentoo-1352d0e851be7a3e5f3f0e629835737b6bbc1400.tar.gz
gentoo-1352d0e851be7a3e5f3f0e629835737b6bbc1400.tar.bz2
gentoo-1352d0e851be7a3e5f3f0e629835737b6bbc1400.zip
dev-python/Levenshtein: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Levenshtein/Levenshtein-0.22.0.ebuild')
-rw-r--r--dev-python/Levenshtein/Levenshtein-0.22.0.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/Levenshtein/Levenshtein-0.22.0.ebuild b/dev-python/Levenshtein/Levenshtein-0.22.0.ebuild
deleted file mode 100644
index c9d35f976f51..000000000000
--- a/dev-python/Levenshtein/Levenshtein-0.22.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-# custom wrapper over setuptools
-DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Functions for fast computation of Levenshtein distance, and edit operations"
-HOMEPAGE="
- https://pypi.org/project/Levenshtein/
- https://github.com/maxbachmann/Levenshtein/
-"
-SRC_URI="
- https://github.com/maxbachmann/Levenshtein/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-DEPEND="
- >=dev-cpp/rapidfuzz-cpp-2.0.0
-"
-RDEPEND="
- <dev-python/rapidfuzz-4.0.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/cython-3.0.2[${PYTHON_USEDEP}]
- >=dev-python/scikit-build-0.13.0[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # sterilize build flags
- sed -i -e '/CMAKE_INTERPROCEDURAL_OPTIMIZATION/d' CMakeLists.txt || die
-
- distutils-r1_src_prepare
-}