summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-10 06:53:31 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-10 07:05:31 +0200
commitaa248549b67f3fd5079eda3e8a840981c8909fd7 (patch)
tree84e7bf2e0d2bb1127fff3afb5f75b484e2d7a8df /dev-python/Levenshtein/Levenshtein-0.23.0.ebuild
parentdev-python/h5py: Bump to 3.10.0 (diff)
downloadgentoo-aa248549b67f3fd5079eda3e8a840981c8909fd7.tar.gz
gentoo-aa248549b67f3fd5079eda3e8a840981c8909fd7.tar.bz2
gentoo-aa248549b67f3fd5079eda3e8a840981c8909fd7.zip
dev-python/Levenshtein: Bump to 0.23.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Levenshtein/Levenshtein-0.23.0.ebuild')
-rw-r--r--dev-python/Levenshtein/Levenshtein-0.23.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/Levenshtein/Levenshtein-0.23.0.ebuild b/dev-python/Levenshtein/Levenshtein-0.23.0.ebuild
new file mode 100644
index 000000000000..72431dbaab2c
--- /dev/null
+++ b/dev-python/Levenshtein/Levenshtein-0.23.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+# custom wrapper over setuptools
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Functions for fast computation of Levenshtein distance, and edit operations"
+HOMEPAGE="
+ https://pypi.org/project/Levenshtein/
+ https://github.com/maxbachmann/Levenshtein/
+"
+SRC_URI="
+ https://github.com/maxbachmann/Levenshtein/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+DEPEND="
+ >=dev-cpp/rapidfuzz-cpp-2.0.0
+"
+RDEPEND="
+ <dev-python/rapidfuzz-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/rapidfuzz-3.1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/cython-3.0.2[${PYTHON_USEDEP}]
+ >=dev-python/scikit-build-0.13.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # sterilize build flags
+ sed -i -e '/CMAKE_INTERPROCEDURAL_OPTIMIZATION/d' CMakeLists.txt || die
+
+ distutils-r1_src_prepare
+}