summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-25 05:41:34 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-25 05:41:34 +0200
commitdc63ac5a31b00a69b36d0a9b8ee0a7fb06596405 (patch)
treeea8202c6eee20359a32d879025094eddf88e9435 /dev-python/Levenshtein/Levenshtein-0.25.0.ebuild
parentdev-lang/python: Remove old (diff)
downloadgentoo-dc63ac5a31b00a69b36d0a9b8ee0a7fb06596405.tar.gz
gentoo-dc63ac5a31b00a69b36d0a9b8ee0a7fb06596405.tar.bz2
gentoo-dc63ac5a31b00a69b36d0a9b8ee0a7fb06596405.zip
dev-python/Levenshtein: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Levenshtein/Levenshtein-0.25.0.ebuild')
-rw-r--r--dev-python/Levenshtein/Levenshtein-0.25.0.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/Levenshtein/Levenshtein-0.25.0.ebuild b/dev-python/Levenshtein/Levenshtein-0.25.0.ebuild
deleted file mode 100644
index 9fe740dcf45b..000000000000
--- a/dev-python/Levenshtein/Levenshtein-0.25.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-# custom wrapper over setuptools
-DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Functions for fast computation of Levenshtein distance, and edit operations"
-HOMEPAGE="
- https://pypi.org/project/Levenshtein/
- https://github.com/rapidfuzz/Levenshtein/
-"
-SRC_URI="
- https://github.com/rapidfuzz/Levenshtein/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-DEPEND="
- <dev-cpp/rapidfuzz-cpp-4
- >=dev-cpp/rapidfuzz-cpp-3.0.0
-"
-RDEPEND="
- <dev-python/rapidfuzz-4.0.0[${PYTHON_USEDEP}]
- >=dev-python/rapidfuzz-3.1.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/cython-3.0.2[${PYTHON_USEDEP}]
- >=dev-python/scikit-build-0.13.0[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # sterilize build flags
- sed -i -e '/CMAKE_INTERPROCEDURAL_OPTIMIZATION/d' CMakeLists.txt || die
-
- distutils-r1_src_prepare
-}