summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-25 14:35:38 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-25 17:36:55 +0200
commite5497107b4ad6ce25479d86bd59ceda06454060d (patch)
treef99dc14a06e94db52c6863c5dca21304f8c76cd0 /dev-python/Nuitka
parentdev-python/Nuitka: Remove old (diff)
downloadgentoo-e5497107b4ad6ce25479d86bd59ceda06454060d.tar.gz
gentoo-e5497107b4ad6ce25479d86bd59ceda06454060d.tar.bz2
gentoo-e5497107b4ad6ce25479d86bd59ceda06454060d.zip
dev-python/Nuitka: Bump to 1.6.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Nuitka')
-rw-r--r--dev-python/Nuitka/Manifest1
-rw-r--r--dev-python/Nuitka/Nuitka-1.6.5.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/Nuitka/Manifest b/dev-python/Nuitka/Manifest
index 6282dea572bb..2614cf29cadb 100644
--- a/dev-python/Nuitka/Manifest
+++ b/dev-python/Nuitka/Manifest
@@ -1 +1,2 @@
DIST Nuitka-1.6.4.tar.gz 4254226 BLAKE2B ec20d567f83bd80c662fefd897c224712735b11df8716fbc039f2413a5cb14433fcf3a893003109065a186911af71cd837892d9c767e92447b3a73bc09afcbf2 SHA512 5fed27a7bea2632ffd6bd802880dcf2372da72f5b1b02221d25322f49c130a1191469495d023c0dd1e25d2326d24385b978c6e9e36e0326c47127001715234c9
+DIST Nuitka-1.6.5.tar.gz 4250050 BLAKE2B 66586aa497da1174e0387a1050763760973a601d40cb5a36bdb030df60a2cde7908f30d173a871a136f9efe9798e3eb3ca03a945c2f1c7345c7ad87f3310f90f SHA512 20469e2872ffd4379ea0ce704fb6282aef8d6c5f8459067e0612248dc21de93b3de1282aab3ad5a285b5a198a9771b0b55897576a2420450753eddb3db827feb
diff --git a/dev-python/Nuitka/Nuitka-1.6.5.ebuild b/dev-python/Nuitka/Nuitka-1.6.5.ebuild
new file mode 100644
index 000000000000..f1bec277226a
--- /dev/null
+++ b/dev-python/Nuitka/Nuitka-1.6.5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 flag-o-matic optfeature pypi
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://www.nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-util/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}