summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-08-25 15:23:31 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-08-25 15:23:31 -0500
commita29283a0621bc47f6ad3572635de8447147ef4b1 (patch)
treedffc2816008e03b81376cfb680eb5f6a1bb57bb7 /dev-python/PyECLib/PyECLib-1.5.0.ebuild
parentdev-util/gertty: 1.5.0 stable amd64 and x86 (diff)
downloadgentoo-a29283a0621bc47f6ad3572635de8447147ef4b1.tar.gz
gentoo-a29283a0621bc47f6ad3572635de8447147ef4b1.tar.bz2
gentoo-a29283a0621bc47f6ad3572635de8447147ef4b1.zip
dev-python/PyECLib: 1.5.0 bup
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/PyECLib/PyECLib-1.5.0.ebuild')
-rw-r--r--dev-python/PyECLib/PyECLib-1.5.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/PyECLib/PyECLib-1.5.0.ebuild b/dev-python/PyECLib/PyECLib-1.5.0.ebuild
new file mode 100644
index 000000000000..8ba5f6e1616d
--- /dev/null
+++ b/dev-python/PyECLib/PyECLib-1.5.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils multilib
+
+DESCRIPTION="Messaging API for RPC and notifications over different messaging transports"
+HOMEPAGE="https://pypi.python.org/pypi/PyECLib"
+SRC_URI="mirror://pypi/p/pyeclib/pyeclib-${PV}.tar.gz"
+S="${WORKDIR}/pyeclib-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+CDEPEND="dev-libs/jerasure"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="dev-libs/liberasurecode
+ ${CDEPEND}"