summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-07-29 13:23:29 +0200
committerMarek Szuba <marecki@gentoo.org>2020-07-29 13:32:48 +0200
commit3a2273d2ed23d70324452f15d7b3061ad514cc67 (patch)
tree351434161487bbf7ea08346e4fcd2ced83bf1a15 /dev-python/PyICU/PyICU-2.5.ebuild
parentdev-python/pytools: mark 2020.3.1 stable on amd64 (diff)
downloadgentoo-3a2273d2ed23d70324452f15d7b3061ad514cc67.tar.gz
gentoo-3a2273d2ed23d70324452f15d7b3061ad514cc67.tar.bz2
gentoo-3a2273d2ed23d70324452f15d7b3061ad514cc67.zip
dev-python/pyicu: rename to PyICU
For consistency with upstream. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/PyICU/PyICU-2.5.ebuild')
-rw-r--r--dev-python/PyICU/PyICU-2.5.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/PyICU/PyICU-2.5.ebuild b/dev-python/PyICU/PyICU-2.5.ebuild
new file mode 100644
index 000000000000..aebc83f22dad
--- /dev/null
+++ b/dev-python/PyICU/PyICU-2.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for dev-libs/icu"
+HOMEPAGE="https://github.com/ovalhub/pyicu"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/icu:="
+DEPEND="${RDEPEND}"
+
+DOCS=( CHANGES CREDITS README.md )
+
+distutils_enable_tests pytest